summaryrefslogtreecommitdiffstats
path: root/development/kforth/kforth.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/kforth/kforth.SlackBuild')
-rw-r--r--development/kforth/kforth.SlackBuild109
1 files changed, 82 insertions, 27 deletions
diff --git a/development/kforth/kforth.SlackBuild b/development/kforth/kforth.SlackBuild
index 28c512d4ac..9c6cc8f5ee 100644
--- a/development/kforth/kforth.SlackBuild
+++ b/development/kforth/kforth.SlackBuild
@@ -1,15 +1,37 @@
-#!/bin/sh
-
-# Slackware build script for kforth
-
-# Written by G. Schoenmakers <gschoen@iinet.net.au>
+#!/bin/bash
+
+# Slackware build script for kForth-32 branch 1.x.x
+
+# Copyright 2023 Antonio Leal, Porto Salvo, Oeiras, Portugal
+# Modified by SlackBuilds.org on 2022/03/18
+# Copyright 2022 G. Schoenmakers <gschoen@iinet.net.au>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=kforth
-VERSION=${VERSION:-1.5.2}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-1.8.0}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
-
-MODEL=${MODEL:-x86-linux}
+PKGTYPE=${PKGTYPE:-tgz}
+TARBALL=${TARBALL:-kForth-32-$VERSION}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -19,48 +41,81 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$MODEL-$VERSION.tar.gz
+tar xvf $CWD/$TARBALL.tar.gz
+mv $TARBALL $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
+
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-patch ForthVM.cpp $CWD/ForthVM.diff
-patch Makefile $CWD/Makefile.diff
-VERSION=${VERSION}p1
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+cd src
make
-# There is no "make install" so the following instructions are used to copy
-# the relevant files into the $PKG directory.
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
mkdir -p $PKG/usr/bin
-cp -a kforth $PKG/usr/bin
-cp -a kforth-fast $PKG/usr/bin
+install -Dsv -m 0755 kforth32 $PKG/usr/bin/kforth
+install -Dsv -m 0755 kforth32-fast $PKG/usr/bin/kforth-fast
-mkdir -p $PKG/usr/share/pixmaps
-cp -a kforth.xpm $PKG/usr/share/pixmaps
+mkdir -p $PKG/usr/share/kforth
+cd ../forth-src
+cp -avxu * $PKG/usr/share/kforth
+cd ../doc
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog README examples $PKG/usr/doc/$PRGNAM-$VERSION
+cp *.* $PKG/usr/doc/$PRGNAM-$VERSION
+cp $CWD/dpans94.pdf $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PKG/etc/profile.d
+cat <<EOF >$PKG/etc/profile.d/kforth.sh
+#!/bin/sh
+export KFORTH_DIR=/usr/share/kforth
+EOF
+chmod 0755 $PKG/etc/profile.d/kforth.sh
+
+mkdir -p $PKG/usr/share/pixmaps
+cp $TMP/$PRGNAM-$VERSION/kforth.xpm $PKG/usr/share/pixmaps
+
+mkdir -p $PKG/usr/share/applications
+cp $CWD/kforth.desktop $PKG/usr/share/applications
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE