summaryrefslogtreecommitdiffstats
path: root/development/dao/dao_readline.patch
diff options
context:
space:
mode:
Diffstat (limited to 'development/dao/dao_readline.patch')
-rw-r--r--development/dao/dao_readline.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/development/dao/dao_readline.patch b/development/dao/dao_readline.patch
new file mode 100644
index 0000000000..9a64430da0
--- /dev/null
+++ b/development/dao/dao_readline.patch
@@ -0,0 +1,32 @@
+--- dao-2.0-devel-2014-01-19/CMakeLists.original.txt 2014-04-03 12:27:09.424917752 +0300
++++ dao-2.0-devel-2014-01-19/CMakeLists.txt 2014-04-03 12:29:11.000397849 +0300
+@@ -89,12 +89,12 @@
+ endif(DAO_HAS_FENV)
+
+ # Check whether the system has readline.h or not.
+-find_path(DAO_HAS_READLINE NAMES "readline/readline.h" "readline/history.h")
+-if(DAO_HAS_READLINE)
+- include_directories("${DAO_HAS_READLINE}")
+- add_definitions(-DDAO_USE_READLINE)
+- list(APPEND DAO_SYSTEM_LIBS "readline")
+-endif(DAO_HAS_READLINE)
++# find_path(DAO_HAS_READLINE NAMES "readline/readline.h" "readline/history.h")
++# if(DAO_HAS_READLINE)
++# include_directories("${DAO_HAS_READLINE}")
++# add_definitions(-DDAO_USE_READLINE)
++# list(APPEND DAO_SYSTEM_LIBS "readline")
++# endif(DAO_HAS_READLINE)
+
+ # Setup for Minix:
+ if( "${CMAKE_SYSTEM_NAME}" STREQUAL "Minix" )
+@@ -199,8 +199,8 @@
+ RUNTIME DESTINATION "bin"
+ LIBRARY DESTINATION "lib"
+ ARCHIVE DESTINATION "lib"
+- PRIVATE_HEADER DESTINATION "include"
+- PUBLIC_HEADER DESTINATION "include"
++ PRIVATE_HEADER DESTINATION "include/dao"
++ PUBLIC_HEADER DESTINATION "include/dao"
+ )
+ #autobind.dao is obsolete:
+ #install(FILES "${PROJECT_SOURCE_DIR}/tools/autobind.dao" DESTINATION "bin")