summaryrefslogtreecommitdiffstats
path: root/development/cppunit/cppunit.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/cppunit/cppunit.SlackBuild')
-rw-r--r--development/cppunit/cppunit.SlackBuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/development/cppunit/cppunit.SlackBuild b/development/cppunit/cppunit.SlackBuild
index c1437f07ad..3fc2fe8da1 100644
--- a/development/cppunit/cppunit.SlackBuild
+++ b/development/cppunit/cppunit.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for CppUnit
-# Copyright 2014-2017 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2014-2020 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=cppunit
-VERSION=${VERSION:-1.14.0}
+VERSION=${VERSION:-1.15.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -43,10 +53,7 @@ OUTPUT=${OUTPUT:-/tmp}
# Makefile.am handles AUTHORS, BUGS, CodingGuideLines.txt, INSTALL*, doc/FAQ
DOCS="COPYING ChangeLog NEWS README THANKS TODO"
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i586" ]; then
+if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
@@ -93,6 +100,7 @@ autoreconf -vif
CXXFLAGS="$SLKCFLAGS" \
make
+make check
make install-strip DESTDIR=$PKG
find $PKG/usr/lib${LIBDIRSUFFIX} -name '*.la' -delete
@@ -105,4 +113,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE