summaryrefslogtreecommitdiffstats
path: root/development/Sphinx
diff options
context:
space:
mode:
Diffstat (limited to 'development/Sphinx')
-rw-r--r--development/Sphinx/README10
-rw-r--r--development/Sphinx/Sphinx.SlackBuild33
-rw-r--r--development/Sphinx/Sphinx.info12
3 files changed, 29 insertions, 26 deletions
diff --git a/development/Sphinx/README b/development/Sphinx/README
index cfd397e4f1..e3f923a7f7 100644
--- a/development/Sphinx/README
+++ b/development/Sphinx/README
@@ -3,13 +3,3 @@ source files into various output formats, including HTML, ePub,
LaTeX and plain text. Sphinx was originally created for the Python
documentation, but it has excellent facilities for the documentation
of software projects in a range of languages.
-
-All Sphinx dependencies must be built with Python 3 support and since
-there are many different way of providing this, the following packages
-require special build instructions not captured in REQUIRES:
-- python/python-urllib3: install python/python3 first
-- python/idna: install python/python3 first
-- python/python-chardet: install python/python3 first
-- python/imagesize: install python/python3 first
-- python/alabaster: install python/python3 first
-- python/pytz: install python/python3 first
diff --git a/development/Sphinx/Sphinx.SlackBuild b/development/Sphinx/Sphinx.SlackBuild
index a102d6c29b..330564c274 100644
--- a/development/Sphinx/Sphinx.SlackBuild
+++ b/development/Sphinx/Sphinx.SlackBuild
@@ -1,7 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for Sphinx
+# Copyright 2023-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2013 Mikko Värri, Finland
# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
@@ -23,10 +24,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=Sphinx
-VERSION=${VERSION:-3.4.1}
+SRCNAM=Sphinx
+VERSION=${VERSION:-5.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +41,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -46,17 +55,21 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# lower Pygments required version
+sed -i '/Pygments>=/ s/2.12/2.10.0/' pyproject.toml
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -71,4 +84,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/Sphinx/Sphinx.info b/development/Sphinx/Sphinx.info
index 605f29c0d3..9d05ca57e9 100644
--- a/development/Sphinx/Sphinx.info
+++ b/development/Sphinx/Sphinx.info
@@ -1,10 +1,10 @@
PRGNAM="Sphinx"
-VERSION="3.4.1"
+VERSION="5.3.0"
HOMEPAGE="http://www.sphinx-doc.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/S/Sphinx/Sphinx-3.4.1.tar.gz"
-MD5SUM="0a110239ba7dedb6670e43d409760e3a"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/S/Sphinx/Sphinx-5.3.0.tar.gz"
+MD5SUM="b752f7b0177865a36cbcdcef4ac80cd4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="alabaster imagesize python3-babel docutils Jinja2 python3-packaging Pygments python-requests python3-six snowballstemmer sphinxcontrib-applehelp sphinxcontrib-devhelp sphinxcontrib-htmlhelp sphinxcontrib-jsmath sphinxcontrib-qthelp sphinxcontrib-serializinghtml python-certifi"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="alabaster imagesize python3-babel snowballstemmer sphinxcontrib-applehelp sphinxcontrib-devhelp sphinxcontrib-htmlhelp sphinxcontrib-jsmath sphinxcontrib-qthelp sphinxcontrib-serializinghtml python-importlib_metadata"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"