summaryrefslogtreecommitdiffstats
path: root/development/Editra
diff options
context:
space:
mode:
Diffstat (limited to 'development/Editra')
-rw-r--r--development/Editra/Editra.SlackBuild93
-rw-r--r--development/Editra/Editra.desktop9
-rw-r--r--development/Editra/Editra.info10
-rw-r--r--development/Editra/README12
-rw-r--r--development/Editra/doinst.sh3
-rw-r--r--development/Editra/slack-desc19
6 files changed, 0 insertions, 146 deletions
diff --git a/development/Editra/Editra.SlackBuild b/development/Editra/Editra.SlackBuild
deleted file mode 100644
index 71146def0a..0000000000
--- a/development/Editra/Editra.SlackBuild
+++ /dev/null
@@ -1,93 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Editra
-
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=Editra
-VERSION=${VERSION:-0.7.20}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/share/applications
-install -D -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
-
-mkdir -p $PKG/usr/share/pixmaps/
-install -D -m644 pixmaps/${PRGNAM,,}.png $PKG/usr/share/pixmaps/${PRGNAM,,}.png
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CHANGELOG COPYING FAQ NEWS README THANKS TODO docs/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/Editra/Editra.desktop b/development/Editra/Editra.desktop
deleted file mode 100644
index 4c0b5d8e60..0000000000
--- a/development/Editra/Editra.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=A Developer's Text Editor
-Name[he]= Editra
-Exec=editra
-Icon=editra
-Terminal=false
-Type=Application
-Categories=Development;TextEditor;
-GenericName=Editor
diff --git a/development/Editra/Editra.info b/development/Editra/Editra.info
deleted file mode 100644
index 8ad529287c..0000000000
--- a/development/Editra/Editra.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Editra"
-VERSION="0.7.20"
-HOMEPAGE="http://www.editra.org/"
-DOWNLOAD="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/editra/Editra-0.7.20.tar.gz"
-MD5SUM="a52c6b3d703f98e0390aa7b44f991616"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="wxPython"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/development/Editra/README b/development/Editra/README
deleted file mode 100644
index 8a501fdb97..0000000000
--- a/development/Editra/README
+++ /dev/null
@@ -1,12 +0,0 @@
-Editra is a multi-platform text editor with an implementation that focuses
-on creating an easy to use nterface and features that aid in code development.
-Currently it supports syntax ighlighting and variety of other useful features
-for over 60 programming languages.
-
-Editra is freely available for use under the terms of the wxWindows License.
-
-Currently the project is in the alpha development phase but test builds of
-"stable" points are available for download and trial as Windows and Mac OSX
-(Universal) binaries, currently other Unix and Linux based systems will have
-to install from source using the included setup script. Please feel free give
-it a try and to report bugs and request features.
diff --git a/development/Editra/doinst.sh b/development/Editra/doinst.sh
deleted file mode 100644
index 473345de20..0000000000
--- a/development/Editra/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/development/Editra/slack-desc b/development/Editra/slack-desc
deleted file mode 100644
index 6eda73a83e..0000000000
--- a/development/Editra/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Editra: Editra (A Developer's Text Editor)
-Editra:
-Editra: Editra is a multi-platform text editor with an implementation that
-Editra: focuses on creating an easy to use interface and features that aid in
-Editra: code development. Currently it supports syntax highlighting and
-Editra: variety of other useful features for over 60 programming languages.
-Editra:
-Editra: Editra is freely available for use under the terms of the wxWindows
-Editra: License.
-Editra: Homepage : http://www.editra.org/
-Editra: