summaryrefslogtreecommitdiffstats
path: root/desktop/yad/yad.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/yad/yad.SlackBuild')
-rw-r--r--desktop/yad/yad.SlackBuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/desktop/yad/yad.SlackBuild b/desktop/yad/yad.SlackBuild
index 38c4e440e6..0295c660be 100644
--- a/desktop/yad/yad.SlackBuild
+++ b/desktop/yad/yad.SlackBuild
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=yad
-VERSION=${VERSION:-0.28.1}
+VERSION=${VERSION:-0.31.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -55,6 +55,8 @@ else
LIBDIRSUFFIX=""
fi
+if pkg-config --exists webkit-1.0 ; then HTML="--enable-html" ; else HTML="" ; fi
+
set -e
rm -rf $PKG
@@ -70,6 +72,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fix location of rgb.txt
+sed -i "s|/etc/X11/rgb\.txt|/usr/share/X11/rgb.txt|" configure.ac
+autoreconf -fi
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -79,6 +85,9 @@ CXXFLAGS="$SLKCFLAGS" \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
+ --with-rgb=/usr/share/X11/rgb.txt \
+ --enable-icon-browser \
+ $HTML \
--build=$ARCH-slackware-linux
make