summaryrefslogtreecommitdiffstats
path: root/desktop/wmakerconf/wmakerconf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/wmakerconf/wmakerconf.SlackBuild')
-rw-r--r--desktop/wmakerconf/wmakerconf.SlackBuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/desktop/wmakerconf/wmakerconf.SlackBuild b/desktop/wmakerconf/wmakerconf.SlackBuild
index a971aba9b7..54ee03c70c 100644
--- a/desktop/wmakerconf/wmakerconf.SlackBuild
+++ b/desktop/wmakerconf/wmakerconf.SlackBuild
@@ -7,12 +7,12 @@
PRGNAM=wmakerconf
VERSION=${VERSION:-2.12}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-4}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -23,8 +23,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -53,14 +53,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix for building over windowmaer >= 0.95.2
-# http://sourceforge.net/tracker/?func=detail&aid=3522083&group_id=196469&atid=957581
-patch -p1 < $CWD/wmakerconf-2.12-wmaker-0.95_support.patch
+# Use freebsd patches, as the *BSD seem the only one who still keep maintaining this...
+for i in $CWD/patches/* ; do patch -p0 < $i ; done
-# Fix linking to X11 libs
-sed -e "/^LIBS =/s/$/ -lX11/" -i src/Makefile.in
+# Fix linking
+sed -e "/^LIBS =/s/$/ -lX11 -lWUtil/" -i src/Makefile.in
-CFLAGS="$SLKCFLAGS" \
+CFLAGS="$SLKCFLAGS -Wno-deprecated-declarations" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \