summaryrefslogtreecommitdiffstats
path: root/desktop/sun/sun.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/sun/sun.SlackBuild')
-rw-r--r--desktop/sun/sun.SlackBuild22
1 files changed, 18 insertions, 4 deletions
diff --git a/desktop/sun/sun.SlackBuild b/desktop/sun/sun.SlackBuild
index 489809c899..ed30f5c3d9 100644
--- a/desktop/sun/sun.SlackBuild
+++ b/desktop/sun/sun.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sun
-# Copyright 2015-2021 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sun
-VERSION=${VERSION:-1.3.1}
+VERSION=${VERSION:-1.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,13 +79,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
+
+# Install configuration and data files
+mkdir -p $PKG/usr/sbin $PKG/etc/$PRGNAM $PKG/usr/share/pixmaps/ $PKG/usr/share/applications/ \
+ $PKG/etc/xdg/autostart/
+
+install -D -m0644 conf/sun.toml $PKG/etc/sun/sun.toml.new
+install -D -m0644 conf/repositories.toml $PKG/etc/sun/repositories.toml.new
+
+mv $PKG/usr/bin/sun-autostart $PKG/usr/sbin/
+cp -a extra/icon/sun.png $PKG/usr/share/pixmaps/
+cp -a extra/desktop/sun.desktop $PKG/usr/share/applications/
+cp -a extra/xdg/sun-daemon.desktop.sample $PKG/etc/xdg/autostart/
+cp -a extra/xdg/sun.desktop $PKG/etc/xdg/autostart/
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst CHANGES.md LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md CHANGELOG.md LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install