summaryrefslogtreecommitdiffstats
path: root/desktop/screenkey
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/screenkey')
-rw-r--r--desktop/screenkey/screenkey.SlackBuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/desktop/screenkey/screenkey.SlackBuild b/desktop/screenkey/screenkey.SlackBuild
index 3c49cc8b07..13e7f1b4b0 100644
--- a/desktop/screenkey/screenkey.SlackBuild
+++ b/desktop/screenkey/screenkey.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for screenkey
-# Copyright 2013 Benjamin Trigona-Harany
+# Copyright 2013-2019 Benjamin Trigona-Harany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=screenkey
VERSION=${VERSION:-0.9}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,8 +71,13 @@ find -L . \
python setup.py install --root=$PKG
+install -D -m 0644 data/$PRGNAM.desktop \
+ $PKG/usr/share/applications/$PRGNAM.desktop
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING.txt NEWS.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING.txt NEWS.rst README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install