summaryrefslogtreecommitdiffstats
path: root/desktop/python3-autotiling
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/python3-autotiling')
-rw-r--r--desktop/python3-autotiling/README5
-rw-r--r--desktop/python3-autotiling/python3-autotiling.SlackBuild83
-rw-r--r--desktop/python3-autotiling/python3-autotiling.info10
-rw-r--r--desktop/python3-autotiling/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/desktop/python3-autotiling/README b/desktop/python3-autotiling/README
new file mode 100644
index 0000000000..68d87ad9f5
--- /dev/null
+++ b/desktop/python3-autotiling/README
@@ -0,0 +1,5 @@
+python3-autotiling (i3/sway window tiling switches)
+
+This script uses the i3ipc-python library to switch the layout
+splith/splitv depending on the currently focused window dimensions.
+It works on both sway and i3 window managers.
diff --git a/desktop/python3-autotiling/python3-autotiling.SlackBuild b/desktop/python3-autotiling/python3-autotiling.SlackBuild
new file mode 100644
index 0000000000..c9b1345e52
--- /dev/null
+++ b/desktop/python3-autotiling/python3-autotiling.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/bash
+
+# Slackware build script for python3-autotiling
+
+# Copyright 2022-2024 Jay Lanagan (j@lngn.net),Detroit, MI, USA.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-autotiling
+SRCNAM=autotiling
+VERSION=${VERSION:-1.9.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$(basename $0) > $PKG/usr/doc/$PRGNAM-$VERSION/$(basename $0)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/python3-autotiling/python3-autotiling.info b/desktop/python3-autotiling/python3-autotiling.info
new file mode 100644
index 0000000000..e8e4b126cf
--- /dev/null
+++ b/desktop/python3-autotiling/python3-autotiling.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-autotiling"
+VERSION="1.9.3"
+HOMEPAGE="https://github.com/nwg-piotr/autotiling"
+DOWNLOAD="https://github.com/nwg-piotr/autotiling/archive/v1.9.3/autotiling-1.9.3.tar.gz"
+MD5SUM="03e10a3ea96e6899b1da84a1c61d480b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="i3ipc"
+MAINTAINER="Jay Lanagan"
+EMAIL="j@lngn.net"
diff --git a/desktop/python3-autotiling/slack-desc b/desktop/python3-autotiling/slack-desc
new file mode 100644
index 0000000000..38b99153c5
--- /dev/null
+++ b/desktop/python3-autotiling/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-autotiling: python3-autotiling (i3/sway window tiling switches)
+python3-autotiling:
+python3-autotiling: This script uses the i3ipc-python library to switch the layout
+python3-autotiling: splith/splitv depending on the currently focused window dimensions.
+python3-autotiling: It works on both sway and i3 window managers.
+python3-autotiling:
+python3-autotiling: Homepage: https://github.com/nwg-piotr/autotiling
+python3-autotiling:
+python3-autotiling:
+python3-autotiling:
+python3-autotiling: