summaryrefslogtreecommitdiffstats
path: root/desktop/py3status
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/py3status')
-rw-r--r--desktop/py3status/README2
-rw-r--r--desktop/py3status/py3status.SlackBuild30
-rw-r--r--desktop/py3status/py3status.info10
3 files changed, 24 insertions, 18 deletions
diff --git a/desktop/py3status/README b/desktop/py3status/README
index a8950b00bb..39c8b78c33 100644
--- a/desktop/py3status/README
+++ b/desktop/py3status/README
@@ -5,4 +5,4 @@ Using py3status, you can take control of your i3bar easily by:
- handling click events on your i3bar and play with them in no time
- seeing your clock tick every second whatever your i3status interval
-Optional dependencies: i3status, python3
+Optional dependencies: i3status
diff --git a/desktop/py3status/py3status.SlackBuild b/desktop/py3status/py3status.SlackBuild
index eb2b310e72..3108d7ee17 100644
--- a/desktop/py3status/py3status.SlackBuild
+++ b/desktop/py3status/py3status.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for py3status
-# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=py3status
-VERSION=${VERSION:-3.22}
+VERSION=${VERSION:-3.55}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,18 +79,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -88,4 +94,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/py3status/py3status.info b/desktop/py3status/py3status.info
index 3a6ef46d6d..ddcb0e89a6 100644
--- a/desktop/py3status/py3status.info
+++ b/desktop/py3status/py3status.info
@@ -1,10 +1,10 @@
PRGNAM="py3status"
-VERSION="3.22"
+VERSION="3.55"
HOMEPAGE="https://github.com/ultrabug/py3status"
-DOWNLOAD="https://files.pythonhosted.org/packages/8c/5e/38e13e14d877c3fee3ca6d6139812815e8f4038c33be9066548698822b14/py3status-3.22.tar.gz"
-MD5SUM="12adc31cd0caa6012e83ce8cd51139ab"
+DOWNLOAD="https://github.com/ultrabug/py3status/archive/refs/tags/3.55/py3status-3.55.tar.gz"
+MD5SUM="fa786d5e87c40083d496ec3c1452a5b6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-hatchling"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"