summaryrefslogtreecommitdiffstats
path: root/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild')
-rw-r--r--desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild45
1 files changed, 33 insertions, 12 deletions
diff --git a/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild b/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild
index 948814297b..50ba66b12d 100644
--- a/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild
+++ b/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild
@@ -1,8 +1,10 @@
-#!/bin/sh
+#!/bin/bash
#
-# Slackware build script for numix-icon-theme-square.
+# Slackware build script for numix-icon-theme-square
#
-# Copyright 2016-2017 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# Copyright 2015-2018 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2023 Edinaldo P. Silva, Rio de Janeiro, Brazil.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,40 +24,59 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM="numix-icon-theme-square"
-VERSION=${VERSION:-20170926}
+VERSION=${VERSION:-23.11.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
ARCH=noarch
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-CWD=$(pwd)
-
-SRCVER=${SRCVER:-1.0.1+11~201709261930~ubuntu17.10.1}
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRCVER
-tar xvf $CWD/${PRGNAM}_${SRCVER}.tar.xz
-cd $PRGNAM-$SRCVER
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
mkdir -p $PKG/usr/share/icons
cp -r Numix-Square Numix-Square-Light $PKG/usr/share/icons
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp debian/changelog LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
+# 20200407 bkw: makepkg's symlink search and doinst.sh creation doesn't
+# scale well. This makes the build complete much faster, and create an
+# identical doinst.sh.
+# there's a broken symlink from upstream, but we leave it behind
+# see https://github.com/SlackBuildsOrg/slackbuilds/pull/4187
+# for discussion
+
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+find . -type l \
+ -printf '( cd %h ; rm -rf %f )\n( cd %h ; ln -sf %l %f )\n' -delete | \
+ sed 's,cd \./,cd ,' >> $PKG/install/doinst.sh
+
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE