summaryrefslogtreecommitdiffstats
path: root/desktop/devilspie/devilspie.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/devilspie/devilspie.SlackBuild')
-rw-r--r--desktop/devilspie/devilspie.SlackBuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/desktop/devilspie/devilspie.SlackBuild b/desktop/devilspie/devilspie.SlackBuild
index 471bd18014..b342469013 100644
--- a/desktop/devilspie/devilspie.SlackBuild
+++ b/desktop/devilspie/devilspie.SlackBuild
@@ -1,12 +1,15 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for devilspie
# Written by Phillip Warner <pc_warner@yahoo.com>
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=devilspie
VERSION=${VERSION:-0.22}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -16,7 +19,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -55,7 +65,7 @@ sed -i -e '/-DG.*_DISABLE_DEPRECATED/d' src/Makefile.am
autoreconf -i
LDFLAGS="-lX11" \
-CFLAGS="$SLKCFLAGS" \
+CFLAGS="$SLKCFLAGS -Wno-error=format-y2k" \
CPPFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -81,4 +91,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE