summaryrefslogtreecommitdiffstats
path: root/desktop/compton/compton.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/compton/compton.SlackBuild')
-rw-r--r--desktop/compton/compton.SlackBuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/desktop/compton/compton.SlackBuild b/desktop/compton/compton.SlackBuild
index a72d5cb66e..f9133cac40 100644
--- a/desktop/compton/compton.SlackBuild
+++ b/desktop/compton/compton.SlackBuild
@@ -22,7 +22,7 @@
# not, see <http://www.gnu.org/licenses/>.
PRGNAM="compton"
-VERSION=${VERSION:-316eac0613bf342ff91cc645a6c3c80e6b9083fb}
+VERSION=${VERSION:-7.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -58,9 +58,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-${VERSION}
-tar xvf $CWD/$PRGNAM-${VERSION}.tar.gz || exit 1
-cd ${PRGNAM}-${VERSION}
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -68,19 +68,25 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-make || exit 1
-make install DESTDIR=$PKG
+sed -i "s|'no-unknown-warning-option',\ ||" meson.build
+cp $CWD/meson.build $CWD/test.h subprojects/test.h/
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+meson build . -D build_docs=true -D b_ndebug=true --prefix=/usr
+DESTDIR=$PKG ninja -C build install
+
+mv $PKG/usr/share/man $PKG/usr/man
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mv $PKG/usr/share/man $PKG/usr/man
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+install -D -m 0644 $PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+install -D -m 0644 $PRGNAM.sample.conf $PKG/etc/$PRGNAM.conf
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -ar \
- desc.txt dbus-examples compton.sample.conf LICENSE \
+ desc.txt dbus-examples compton.sample.conf COPYING LICENSES \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild