summaryrefslogtreecommitdiffstats
path: root/desktop/cairo-dock-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/cairo-dock-plugins')
-rw-r--r--desktop/cairo-dock-plugins/README2
-rw-r--r--desktop/cairo-dock-plugins/cairo-dock-plugins.SlackBuild30
-rw-r--r--desktop/cairo-dock-plugins/cairo-dock-plugins.info6
-rw-r--r--desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-0001-demo_ruby-fix-traceback-when-changing-themes.patch40
-rw-r--r--desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-0004-weather-update-URL.patch52
-rw-r--r--desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-mono.patch106
-rw-r--r--desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-port-WebKit2.patch77
-rw-r--r--desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-time_h-confict.patch137
8 files changed, 434 insertions, 16 deletions
diff --git a/desktop/cairo-dock-plugins/README b/desktop/cairo-dock-plugins/README
index d758f4c722..496a240ad9 100644
--- a/desktop/cairo-dock-plugins/README
+++ b/desktop/cairo-dock-plugins/README
@@ -3,4 +3,4 @@ plug-ins for Cairo-Dock It provides some new functionnalities like
controling music players or note-taking, a clock or a desktop
switcher but also some views, dialogs and desklets skins, etc.
-vala, python3 and mono are optional dependencies.
+libetpan, vala, python3 and mono are optional dependencies.
diff --git a/desktop/cairo-dock-plugins/cairo-dock-plugins.SlackBuild b/desktop/cairo-dock-plugins/cairo-dock-plugins.SlackBuild
index 1ef6650ec5..11c932e67e 100644
--- a/desktop/cairo-dock-plugins/cairo-dock-plugins.SlackBuild
+++ b/desktop/cairo-dock-plugins/cairo-dock-plugins.SlackBuild
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=cairo-dock-plugins
-VERSION=${VERSION:-3.3.2}
+VERSION=${VERSION:-3.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -59,9 +59,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
+rm -rf cairo-dock-plug-ins-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+cd cairo-dock-plug-ins-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,25 +69,31 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Thanks to fedora and archlinux
+for i in $CWD/patches/* ; do patch -p1 < $i ; done
+sed -i -e 's|-Wno-all||' Dbus/interfaces/vala/src/CMakeLists.txt
+
+mkdir build
+cd build
cmake \
-DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release .
+ -DCMAKE_BUILD_TYPE=Release ..
make VERBOSE=1
make install DESTDIR=$PKG
+cd ..
# Sheesh. Donchaloveruby?
-mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/ruby/1.9.1
+RUBY_SITELIBDIR=$(ruby -e 'print RbConfig::CONFIG["sitelibdir"]')
+mkdir -p $PKG$RUBY_SITELIBDIR
if [ -d $PKG/usr/usr ]; then
- mv $PKG/usr/usr/lib${LIBDIRSUFFIX}/ruby/1.9.1/CDApplet.rb \
- $PKG/usr/lib${LIBDIRSUFFIX}/ruby/1.9.1
+ mv $PKG/usr$RUBY_SITELIBDIR/CDApplet.rb $PKG$RUBY_SITELIBDIR/
rm -rf $PKG/usr/usr
elif [ -e $PKG/usr/CDApplet.rb ]; then
- mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/ruby/1.9.1
- mv $PKG/usr/CDApplet.rb $PKG/usr/lib${LIBDIRSUFFIX}/ruby/1.9.1
+ mv $PKG/usr/CDApplet.rb $PKG$RUBY_SITELIBDIR/
fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/desktop/cairo-dock-plugins/cairo-dock-plugins.info b/desktop/cairo-dock-plugins/cairo-dock-plugins.info
index b28117ab5d..3fb0f52e51 100644
--- a/desktop/cairo-dock-plugins/cairo-dock-plugins.info
+++ b/desktop/cairo-dock-plugins/cairo-dock-plugins.info
@@ -1,8 +1,8 @@
PRGNAM="cairo-dock-plugins"
-VERSION="3.3.2"
+VERSION="3.4.1"
HOMEPAGE="http://www.glx-dock.org"
-DOWNLOAD="https://launchpad.net/cairo-dock-plug-ins/3.3/3.3.2/+download/cairo-dock-plugins-3.3.2.tar.gz"
-MD5SUM="3c40afe91cba65da68a70e5e78b76c24"
+DOWNLOAD="https://github.com/Cairo-Dock/cairo-dock-plug-ins/archive/3.4.1/cairo-dock-plugins-3.4.1.tar.gz"
+MD5SUM="434941926f9205fd8562a15b6ac5f243"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="cairo-dock"
diff --git a/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-0001-demo_ruby-fix-traceback-when-changing-themes.patch b/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-0001-demo_ruby-fix-traceback-when-changing-themes.patch
new file mode 100644
index 0000000000..846b4176fd
--- /dev/null
+++ b/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-0001-demo_ruby-fix-traceback-when-changing-themes.patch
@@ -0,0 +1,40 @@
+From 9043010e2cdd384ff5de5f5f116229557d15721c Mon Sep 17 00:00:00 2001
+From: Mamoru TASAKA <mtasaka@fedorapeople.org>
+Date: Fri, 6 Mar 2015 19:06:34 +0900
+Subject: [PATCH] demo_ruby: fix traceback when changing themes
+
+Fix the "crash" when changing like:
+./demo_ruby:108:in `reload': undefined local variable or method `myApplet' for #<Applet:0x00000002e6c060> (NameError)
+ from /usr/share/ruby/vendor_ruby/CDApplet.rb:203:in `_on_reload'
+ from /usr/share/ruby/vendor_ruby/CDApplet.rb:274:in `block in _connect_to_dock'
+ from /usr/share/gems/gems/ruby-dbus-0.9.0/lib/dbus/introspect.rb:325:in `call'
+ from /usr/share/gems/gems/ruby-dbus-0.9.0/lib/dbus/introspect.rb:325:in `block in on_signal'
+ from /usr/share/gems/gems/ruby-dbus-0.9.0/lib/dbus/bus.rb:665:in `call'
+ from /usr/share/gems/gems/ruby-dbus-0.9.0/lib/dbus/bus.rb:665:in `block in process'
+ from /usr/share/gems/gems/ruby-dbus-0.9.0/lib/dbus/bus.rb:663:in `each'
+ from /usr/share/gems/gems/ruby-dbus-0.9.0/lib/dbus/bus.rb:663:in `process'
+ from /usr/share/gems/gems/ruby-dbus-0.9.0/lib/dbus/bus.rb:855:in `block in run'
+ from /usr/share/gems/gems/ruby-dbus-0.9.0/lib/dbus/bus.rb:846:in `each'
+ from /usr/share/gems/gems/ruby-dbus-0.9.0/lib/dbus/bus.rb:846:in `run'
+ from /usr/share/ruby/vendor_ruby/CDApplet.rb:83:in `run'
+ from ./demo_ruby:127:in `<main>'
+---
+ Dbus/demos/demo_ruby/demo_ruby | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Dbus/demos/demo_ruby/demo_ruby b/Dbus/demos/demo_ruby/demo_ruby
+index 2df5cda..a9374bd 100755
+--- a/Dbus/demos/demo_ruby/demo_ruby
++++ b/Dbus/demos/demo_ruby/demo_ruby
+@@ -105,7 +105,7 @@ class Applet < CDApplet
+ end
+ def reload
+ p "[+] our module was reloaded, welcome back!"
+- self.icon.AddDataRenderer("gauge", 1, myApplet.config['theme'])
++ self.icon.AddDataRenderer("gauge", 1, self.configuration['theme'])
+ self.icon.RenderValues([Float(self.counter)/self.configuration['max_value']])
+ self.sub_icons.RemoveSubIcon("any")
+ self.sub_icons.AddSubIcons(["icon 1", "firefox-3.0", "id1", "icon 2", "natilus", "id2", "icon 3", "thunderbird", "id3"])
+--
+2.1.0
+
diff --git a/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-0004-weather-update-URL.patch b/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-0004-weather-update-URL.patch
new file mode 100644
index 0000000000..035143fd3d
--- /dev/null
+++ b/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-0004-weather-update-URL.patch
@@ -0,0 +1,52 @@
+From 402a2d7bb657be4ad4072f07612e008e846d5e97 Mon Sep 17 00:00:00 2001
+From: Fabounet <fabounet03@gmail.com>
+Date: Sun, 22 May 2016 21:13:21 +0200
+Subject: [PATCH] [1581725] Updated the weather URL we retrieve data from
+
+---
+ weather/src/applet-config.c | 2 +-
+ weather/src/applet-read-data.c | 3 ---
+ weather/src/applet-struct.h | 3 +++
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/weather/src/applet-config.c b/weather/src/applet-config.c
+index c9a33c2..0a27a8a 100755
+--- a/weather/src/applet-config.c
++++ b/weather/src/applet-config.c
+@@ -174,7 +174,7 @@ static void _on_got_location_data (const gchar *cLocationData, GldiModuleInstanc
+ gldi_task_discard (myData.pGetLocationTask);
+ myData.pGetLocationTask = NULL;
+ }
+-#define CD_WEATHER_BASE_URL "http://xml.weather.com"
++
+ static void _cd_weather_search_for_location (GtkEntry *pEntry, GldiModuleInstance *myApplet)
+ {
+ const gchar *cLocationName = gtk_entry_get_text (pEntry);
+diff --git a/weather/src/applet-read-data.c b/weather/src/applet-read-data.c
+index 0bbdce7..8ca8d21 100755
+--- a/weather/src/applet-read-data.c
++++ b/weather/src/applet-read-data.c
+@@ -30,9 +30,6 @@
+ #include "applet-load-icons.h"
+ #include "applet-read-data.h"
+
+-#define CD_WEATHER_BASE_URL "http://xml.weather.com"
+-
+-
+ static xmlDocPtr _cd_weather_open_xml_buffer (const gchar *cData, xmlNodePtr *root_node, const gchar *cRootNodeName, GError **erreur)
+ {
+ if (cData == NULL || *cData == '\0')
+diff --git a/weather/src/applet-struct.h b/weather/src/applet-struct.h
+index e96191e..02ba3d0 100755
+--- a/weather/src/applet-struct.h
++++ b/weather/src/applet-struct.h
+@@ -29,6 +29,9 @@
+
+ #define WEATHER_DEFAULT_NAME "weather"
+
++#define CD_WEATHER_BASE_URL "http://wxdata.weather.com/wxdata"
++
++
+ #define _display(cValue) ((cValue) == NULL || *((gchar*)cValue) == 'N' ? "?" : (const gchar*)(cValue))
+
+ struct _AppletConfig {
diff --git a/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-mono.patch b/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-mono.patch
new file mode 100644
index 0000000000..637c1ca494
--- /dev/null
+++ b/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-mono.patch
@@ -0,0 +1,106 @@
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/CMakeLists.txt cairo-dock-plug-ins-3.4.1/CMakeLists.txt
+--- cairo-dock-plug-ins-3.4.1.orig/CMakeLists.txt 2015-03-12 09:43:57.171067365 +0100
++++ cairo-dock-plug-ins-3.4.1/CMakeLists.txt 2015-03-12 09:46:20.717120675 +0100
+@@ -573,11 +573,11 @@ if (enable-mono-interface)
+ if (NOT GMCS_EXECUTABLE OR NOT EXISTS ${GMCS_EXECUTABLE})
+ message (STATUS "Could not find Mono compiler gmcs, won't build Mono interface.")
+ else()
+- pkg_check_modules (MONO_PACKAGE glib-sharp-2.0 ndesk-dbus-1.0 ndesk-dbus-glib-1.0)
++ pkg_check_modules (MONO_PACKAGE dbus-sharp-2.0 dbus-sharp-glib-2.0 glib-sharp-3.0)
+ if (NOT MONO_PACKAGE_FOUND)
+- message (STATUS "Could not find glib-sharp-2.0, ndesk-dbus-1.0 or ndesk-dbus-glib-1.0; won't be built Mono interface.")
+- message (WARNING "These modules are required to compile DBus applet with Mono interface: glib-sharp-2.0, ndesk-dbus-1.0 and ndesk-dbus-glib-1.0")
+- set (MODULES_MISSING "${MODULES_MISSING} glib-sharp-2.0 ndesk-dbus-1.0 ndesk-dbus-glib-1.0")
++ message (STATUS "Could not find dbus-sharp-2.0, dbus-sharp-glib-2.0 or glib-sharp-3.0; won't be built Mono interface.")
++ message (WARNING "These modules are required to compile DBus applet with Mono interface: dbus-sharp-2.0, dbus-sharp-glib-2.0 and glib-sharp-3.0")
++ set (MODULES_MISSING "${MODULES_MISSING} dbus-sharp-2.0 dbus-sharp-glib-2.0 glib-sharp-3.0")
+ else()
+ set (MONO_FOUND TRUE)
+ set (with_mono yes)
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/CDApplet.cs cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/CDApplet.cs
+--- cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/CDApplet.cs 2015-03-12 09:52:56.491934965 +0100
++++ cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/CDApplet.cs 2015-03-12 09:56:50.191652099 +0100
+@@ -21,7 +21,7 @@
+ // Make your own class derive from a CDApplet, and override the functions you need (the ones which don't start with an underscore).
+
+ // Compile it with the following command, then rename 'demo_mono.exe' to 'demo_mono'.
+-// gmcs /target:library CDApplet.cs ISubApplet.cs IApplet.cs -pkg:glib-sharp-2.0 -pkg:ndesk-dbus-1.0 -pkg:ndesk-dbus-glib-1.0
++// gmcs /target:library CDApplet.cs ISubApplet.cs IApplet.cs -pkg:dbus-sharp-2.0 -pkg:dbus-sharp-glib-2.0 -pkg:glib-sharp-3.0
+ //////////////////////////
+ ////// dependancies //////
+ //////////////////////////
+@@ -29,7 +29,7 @@ using System; // Environment
+ using System.IO; // Path, Directory
+ using System.Reflection;
+ using GLib;
+-using NDesk.DBus;
++using DBus;
+ using CairoDock.Applet;
+
+ //namespace CairoDock.Applet
+@@ -258,8 +258,8 @@ public class CDApplet
+
+ private void _connect_to_dock ()
+ {
+- NDesk.DBus.BusG.Init();
+- NDesk.DBus.Bus bus = NDesk.DBus.Bus.Session;
++ DBus.BusG.Init();
++ DBus.Bus bus = DBus.Bus.Session;
+ this.icon = bus.GetObject<IApplet> ("org.cairodock.CairoDock", new ObjectPath (this.cBusPath));
+ this.icon.on_click += new OnClickEvent (on_click);
+ this.icon.on_middle_click += new OnMiddleClickEvent (on_middle_click);
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/CMakeLists.txt cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/CMakeLists.txt
+--- cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/CMakeLists.txt 2015-03-12 09:52:56.491934965 +0100
++++ cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/CMakeLists.txt 2015-03-12 09:54:07.418777441 +0100
+@@ -3,7 +3,7 @@
+
+ execute_process(COMMAND ${GMCS_EXECUTABLE}
+ -target:library
+- -pkg:glib-sharp-2.0 -pkg:ndesk-dbus-1.0 -pkg:ndesk-dbus-glib-1.0
++ -pkg:dbus-sharp-2.0 -pkg:dbus-sharp-glib-2.0 -pkg:glib-sharp-3.0
+ -out:${CMAKE_CURRENT_BINARY_DIR}/CDApplet.dll
+ ${CMAKE_CURRENT_SOURCE_DIR}/CDApplet.cs ${CMAKE_CURRENT_SOURCE_DIR}/ISubApplet.cs ${CMAKE_CURRENT_SOURCE_DIR}/IApplet.cs)
+ ### find how to register to GAC ...
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/Dbus/demos/demo_mono/demo_mono.cs cairo-dock-plug-ins-3.4.1/Dbus/demos/demo_mono/demo_mono.cs
+--- cairo-dock-plug-ins-3.4.1.orig/Dbus/demos/demo_mono/demo_mono.cs 2015-03-12 09:59:41.064312097 +0100
++++ cairo-dock-plug-ins-3.4.1/Dbus/demos/demo_mono/demo_mono.cs 2015-03-12 10:02:39.473424651 +0100
+@@ -138,7 +138,7 @@ public class Applet : CDApplet
+ public override void on_build_menu ()
+ {
+ Console.WriteLine("*** build menu");
+- /// Warning : teh AddMenuItems fails with NDesk-DBus 0.6.0; until this is fixed, use the PopulateMenu method.
++ /// Warning : the AddMenuItems fails with DBus Sharp 0.6.0; until this is fixed, use the PopulateMenu method.
+ /**Dictionary<string, object>[] pItems = new Dictionary<string, object>[] {
+ new Dictionary<string, object>()
+ {
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/IApplet.cs cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/IApplet.cs
+--- cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/IApplet.cs 2015-03-12 09:59:41.067645289 +0100
++++ cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/IApplet.cs 2015-03-12 10:00:35.395334804 +0100
+@@ -1,6 +1,6 @@
+ using System;
+ using System.Collections.Generic; // Dictionnary
+-using NDesk.DBus;
++using DBus;
+
+ namespace CairoDock.Applet
+ {
+@@ -27,7 +27,7 @@ namespace CairoDock.Applet
+ Left
+ }
+
+- [NDesk.DBus.Interface("org.cairodock.CairoDock.applet")]
++ [DBus.Interface("org.cairodock.CairoDock.applet")]
+ public interface IApplet
+ {
+ object Get(string cProperty);
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/ISubApplet.cs cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/ISubApplet.cs
+--- cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/ISubApplet.cs 2015-03-12 09:59:41.067645289 +0100
++++ cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/ISubApplet.cs 2015-03-12 10:00:16.522802989 +0100
+@@ -1,6 +1,6 @@
+ using System;
+ using System.Collections.Generic; // Dictionnary
+-using NDesk.DBus;
++using DBus;
+
+ namespace CairoDock.Applet
+ {
diff --git a/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-port-WebKit2.patch b/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-port-WebKit2.patch
new file mode 100644
index 0000000000..bec6e5fcac
--- /dev/null
+++ b/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-port-WebKit2.patch
@@ -0,0 +1,77 @@
+--- cairo-dock-plugins-3.4.1/CMakeLists.txt.wk2 2017-04-01 03:09:09.171381809 +0900
++++ cairo-dock-plugins-3.4.1/CMakeLists.txt 2017-04-01 03:09:09.172381805 +0900
+@@ -1391,7 +1391,7 @@
+ set (with_weblets no)
+ enable_if_not_defined (enable-weblets)
+ if (enable-weblets)
+- set (WEBKIT_MODULE webkitgtk-3.0)
++ set (WEBKIT_MODULE webkit2gtk-4.0)
+ pkg_check_modules (WEBKIT ${WEBKIT_MODULE})
+ if (NOT WEBKIT_FOUND)
+ message (STATUS "Could not find ${WEBKIT_MODULE}; Cairo-Dock won't be built with Weblets applet.")
+--- cairo-dock-plugins-3.4.1/weblets/src/applet-struct.h.wk2 2015-02-20 01:13:47.000000000 +0900
++++ cairo-dock-plugins-3.4.1/weblets/src/applet-struct.h 2017-04-01 03:09:09.172381805 +0900
+@@ -28,7 +28,7 @@
+ #include "config.h"
+ #endif
+
+-#include <webkit/webkit.h>
++#include <webkit2/webkit2.h>
+
+ //\___________ structure containing the applet's configuration parameters.
+ struct _AppletConfig {
+--- cairo-dock-plugins-3.4.1/weblets/src/applet-widget.c.wk2 2015-02-20 01:13:47.000000000 +0900
++++ cairo-dock-plugins-3.4.1/weblets/src/applet-widget.c 2017-04-01 03:14:59.380001735 +0900
+@@ -62,13 +62,19 @@
+ return gldi_dialog_new (&attr);
+ }
+
+-/* Will be called when loading of the page is finished*/
+-void load_finished_cb(WebKitWebView *pWebKitView, WebKitWebFrame* widget
++/* Will be called when loading of the page is changed*/
++void load_changed_cb(WebKitWebView *pWebKitView, WebKitLoadEvent load_event
+ , GldiModuleInstance *myApplet)
+ {
+- cd_debug ("weblets : (re)load finished\n");
+- // update scrollbars status
+- show_hide_scrollbars(myApplet);
++ switch (load_event) {
++ case WEBKIT_LOAD_FINISHED:
++ cd_debug ("weblets : (re)load finished\n");
++ // update scrollbars status
++ show_hide_scrollbars(myApplet);
++ break;
++ default:
++ break;
++ }
+ }
+
+ /* Build the embedded widget */
+@@ -80,8 +86,8 @@
+ myData.pWebKitView = WEBKIT_WEB_VIEW (webkit_web_view_new ());
+ gtk_container_add (GTK_CONTAINER (myData.pGtkMozEmbed), GTK_WIDGET (myData.pWebKitView));
+ g_signal_connect(G_OBJECT(myData.pWebKitView),
+- "load_finished",
+- G_CALLBACK (load_finished_cb),
++ "load-changed",
++ G_CALLBACK (load_changed_cb),
+ myApplet);
+ gtk_widget_show_all (myData.pGtkMozEmbed);
+
+@@ -120,10 +126,14 @@
+ }
+ }
+
+- webkit_web_view_open(WEBKIT_WEB_VIEW(myData.pWebKitView), myConfig.cURI_to_load?myConfig.cURI_to_load:"http://www.google.com");
++ webkit_web_view_load_uri(WEBKIT_WEB_VIEW(myData.pWebKitView), myConfig.cURI_to_load?myConfig.cURI_to_load:"http://www.google.com");
+ }
+ /* available since rev. 30985, from fev. 2008 */
+- webkit_web_view_set_transparent(myData.pWebKitView, myConfig.bIsTransparent);
++ {
++ GdkRGBA rgba = {0};
++ if (myConfig.bIsTransparent) rgba.alpha = 0.5;
++ webkit_web_view_set_background_color(myData.pWebKitView, &rgba);
++ }
+
+ return TRUE;
+ }
diff --git a/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-time_h-confict.patch b/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-time_h-confict.patch
new file mode 100644
index 0000000000..0a2ea720d1
--- /dev/null
+++ b/desktop/cairo-dock-plugins/patches/cairo-dock-plugins-3.4.1-time_h-confict.patch
@@ -0,0 +1,137 @@
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-config.c.glibc 2016-12-11 16:10:41.656840262 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-config.c 2016-12-11 16:23:31.875117800 +0900
+@@ -17,6 +17,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include "applet-time_h-struct.h"
+ #include <string.h>
+
+ #include "applet-struct.h"
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-init.c.glibc 2016-12-11 16:10:41.657840257 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-init.c 2016-12-11 16:22:24.465443591 +0900
+@@ -17,6 +17,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include "applet-time_h-struct.h"
+ #include "stdlib.h"
+
+ #include "applet-struct.h"
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-notifications.c.glibc 2015-02-20 01:13:47.000000000 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-notifications.c 2016-12-11 16:24:08.991938415 +0900
+@@ -17,6 +17,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include "applet-time_h-struct.h"
+ #include <stdlib.h>
+ #include <string.h>
+
+@@ -66,4 +67,4 @@
+
+
+ return GLDI_NOTIFICATION_LET_PASS;
+-}
+\ ファイル末尾に改行がありません
++}
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-sound.c.glibc 2015-02-20 01:13:47.000000000 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-sound.c 2016-12-11 16:23:55.137005376 +0900
+@@ -19,6 +19,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include "applet-time_h-struct.h"
+ #include <stdlib.h>
+ #ifndef __FreeBSD__
+ #include <endian.h>
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-struct.h.glibc 2016-12-11 16:10:41.657840257 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-struct.h 2016-12-11 16:22:59.589273837 +0900
+@@ -21,6 +21,7 @@
+ #ifndef __CD_APPLET_STRUCT__
+ #define __CD_APPLET_STRUCT__
+
++#include "applet-time_h-struct.h"
+ #include <sys/types.h>
+ #include <alsa/asoundlib.h>
+ #define _STRUCT_TIMEVAL
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-time_h-struct.h.glibc 2016-12-11 16:11:55.464483550 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-time_h-struct.h 2016-12-11 16:19:52.003180440 +0900
+@@ -0,0 +1,27 @@
++/**
++* This file is a part of the Cairo-Dock project
++*
++* Copyright : (C) see the 'copyright' file.
++* E-mail : see the 'copyright' file.
++*
++* This program is free software; you can redistribute it and/or
++* modify it under the terms of the GNU General Public License
++* as published by the Free Software Foundation; either version 3
++* of the License, or (at your option) any later version.
++*
++* This program is distributed in the hope that it will be useful,
++* but WITHOUT ANY WARRANTY; without even the implied warranty of
++* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++* GNU General Public License for more details.
++* You should have received a copy of the GNU General Public License
++* along with this program. If not, see <http://www.gnu.org/licenses/>.
++*/
++
++#ifndef __CD_APPLET_TIME_H_STRUCT__
++#define __CD_APPLET_TIME_H_STRUCT__
++
++#define _POSIX_C_SOURCE 200809L
++#include <time.h>
++
++#endif
++
+--- cairo-dock-plugins-3.4.1/alsaMixer/src/applet-generic.c.glibc 2015-02-20 01:13:47.000000000 +0900
++++ cairo-dock-plugins-3.4.1/alsaMixer/src/applet-generic.c 2016-12-11 16:20:44.168928323 +0900
+@@ -20,6 +20,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include "applet-time_h-struct.h"
+ #include <stdlib.h>
+
+ #include "applet-struct.h"
+--- cairo-dock-plugins-3.4.1/alsaMixer/src/applet-struct.h.glibc 2015-02-20 01:13:47.000000000 +0900
++++ cairo-dock-plugins-3.4.1/alsaMixer/src/applet-struct.h 2016-12-11 16:19:47.713201174 +0900
+@@ -20,6 +20,7 @@
+ #ifndef __CD_APPLET_STRUCT__
+ #define __CD_APPLET_STRUCT__
+
++#include "applet-time_h-struct.h"
+ #include <sys/types.h>
+ #include <alsa/asoundlib.h>
+ #define _STRUCT_TIMEVAL
+--- cairo-dock-plugins-3.4.1/alsaMixer/src/applet-time_h-struct.h.glibc 2016-12-11 16:11:55.464483550 +0900
++++ cairo-dock-plugins-3.4.1/alsaMixer/src/applet-time_h-struct.h 2016-12-11 16:19:52.003180440 +0900
+@@ -0,0 +1,27 @@
++/**
++* This file is a part of the Cairo-Dock project
++*
++* Copyright : (C) see the 'copyright' file.
++* E-mail : see the 'copyright' file.
++*
++* This program is free software; you can redistribute it and/or
++* modify it under the terms of the GNU General Public License
++* as published by the Free Software Foundation; either version 3
++* of the License, or (at your option) any later version.
++*
++* This program is distributed in the hope that it will be useful,
++* but WITHOUT ANY WARRANTY; without even the implied warranty of
++* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++* GNU General Public License for more details.
++* You should have received a copy of the GNU General Public License
++* along with this program. If not, see <http://www.gnu.org/licenses/>.
++*/
++
++#ifndef __CD_APPLET_TIME_H_STRUCT__
++#define __CD_APPLET_TIME_H_STRUCT__
++
++#define _POSIX_C_SOURCE 200809L
++#include <time.h>
++
++#endif
++