summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/faac/faac-1.28-external-libmp4v2.patch47
-rw-r--r--audio/faac/faac-1.28-libmp4v2_r479_compat.patch138
-rw-r--r--audio/faac/faac.SlackBuild67
-rw-r--r--audio/faac/faac.info8
4 files changed, 19 insertions, 241 deletions
diff --git a/audio/faac/faac-1.28-external-libmp4v2.patch b/audio/faac/faac-1.28-external-libmp4v2.patch
deleted file mode 100644
index 54a63347b8..0000000000
--- a/audio/faac/faac-1.28-external-libmp4v2.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-diff -ur faac-1.28.orig/configure.in faac-1.28/configure.in
---- faac-1.28.orig/configure.in 2009-02-05 02:55:38.000000000 +0200
-+++ faac-1.28/configure.in 2009-07-10 13:21:34.000000000 +0300
-@@ -28,14 +28,17 @@
- AC_CHECK_LIB(gnugetopt, getopt_long)
-
- AM_CONDITIONAL(WITH_MP4V2, false)
-+AM_CONDITIONAL(WITH_EXTERNAL_MP4V2, false)
-
- AC_CHECK_DECLS([MP4Create, MP4MetadataDelete],
- AC_CHECK_LIB(mp4v2, MP4MetadataDelete, external_mp4v2=yes,
- external_mp4v2=no, -lstdc++),
-- external_mp4v2=no, [#include <mp4.h>])
-+ external_mp4v2=no, [#include <mp4v2/mp4v2.h>])
-
- if test x$external_mp4v2 = xyes; then
- AC_MSG_NOTICE([*** Building with external mp4v2 ***])
-+ MY_DEFINE(HAVE_LIBMP4V2)
-+ AM_CONDITIONAL(WITH_EXTERNAL_MP4V2, true)
- else
- if test x$WITHMP4V2 = xyes; then
- AC_MSG_NOTICE([*** Building with internal mp4v2 ***])
-diff -ur faac-1.28.orig/frontend/main.c faac-1.28/frontend/main.c
---- faac-1.28.orig/frontend/main.c 2009-01-24 03:10:20.000000000 +0200
-+++ faac-1.28/frontend/main.c 2009-07-10 13:22:18.000000000 +0300
-@@ -30,7 +30,7 @@
- #endif
-
- #ifdef HAVE_LIBMP4V2
--# include <mp4.h>
-+# include <mp4v2/mp4v2.h>
- #endif
-
- #define DEFAULT_TNS 0
-diff -ur faac-1.28.orig/frontend/Makefile.am faac-1.28/frontend/Makefile.am
---- faac-1.28.orig/frontend/Makefile.am 2008-12-16 02:56:00.000000000 +0200
-+++ faac-1.28/frontend/Makefile.am 2009-07-10 13:21:55.000000000 +0300
-@@ -8,5 +8,9 @@
- LDADD = $(top_builddir)/libfaac/libfaac.la $(top_srcdir)/common/mp4v2/libmp4v2.a -lm -lstdc++
- else
- INCLUDES = -I$(top_srcdir)/include
-+if WITH_EXTERNAL_MP4V2
-+LDADD = $(top_builddir)/libfaac/libfaac.la -lm -lmp4v2
-+else
- LDADD = $(top_builddir)/libfaac/libfaac.la -lm
- endif
-+endif
diff --git a/audio/faac/faac-1.28-libmp4v2_r479_compat.patch b/audio/faac/faac-1.28-libmp4v2_r479_compat.patch
deleted file mode 100644
index f4ac8e6d4c..0000000000
--- a/audio/faac/faac-1.28-libmp4v2_r479_compat.patch
+++ /dev/null
@@ -1,138 +0,0 @@
-http://bugs.gentoo.org/397575
-http://sourceforge.net/tracker/?func=detail&aid=3476707&group_id=704&atid=100704
-
---- configure.in
-+++ configure.in
-@@ -33,8 +33,8 @@ AC_CHECK_LIB(gnugetopt, getopt_long)
- AM_CONDITIONAL(WITH_MP4V2, false)
- AM_CONDITIONAL(WITH_EXTERNAL_MP4V2, false)
-
--AC_CHECK_DECLS([MP4Create, MP4MetadataDelete],
-- AC_CHECK_LIB(mp4v2, MP4MetadataDelete, external_mp4v2=yes,
-+AC_CHECK_DECLS([MP4Create],
-+ AC_CHECK_LIB(mp4v2, MP4Create, external_mp4v2=yes,
- external_mp4v2=no, -lstdc++),
- external_mp4v2=no, [#include <mp4v2/mp4v2.h>])
-
-@@ -42,6 +42,7 @@ if test x$external_mp4v2 = xyes; then
- AC_MSG_NOTICE([*** Building with external mp4v2 ***])
- MY_DEFINE(HAVE_EXTERNAL_LIBMP4V2)
- AM_CONDITIONAL(WITH_EXTERNAL_MP4V2, true)
-+ AC_CHECK_DECLS([MP4TagsAlloc], [], [], [#include <mp4v2/mp4v2.h>])
- else
- if test x$WITHMP4V2 = xyes; then
- AC_MSG_NOTICE([*** Building with internal mp4v2 ***])
---- frontend/main.c
-+++ frontend/main.c
-@@ -873,8 +873,12 @@ int main(int argc, char *argv[])
- if (!faacEncSetConfiguration(hEncoder, myFormat)) {
- fprintf(stderr, "Unsupported output format!\n");
- #ifdef HAVE_LIBMP4V2
-+#ifdef MP4_CLOSE_DO_NOT_COMPUTE_BITRATE /* r479 fix */
-+ if (container == MP4_CONTAINER) MP4Close(MP4hFile, 0);
-+#else
- if (container == MP4_CONTAINER) MP4Close(MP4hFile);
- #endif
-+#endif
- return 1;
- }
-
-@@ -885,12 +889,10 @@ int main(int argc, char *argv[])
- unsigned long ASCLength = 0;
- char *version_string;
-
--#ifdef MP4_CREATE_EXTENSIBLE_FORMAT
-- /* hack to compile against libmp4v2 >= 1.0RC3
-- * why is there no version identifier in mp4.h? */
-+#ifdef MP4_DETAILS_ERROR /* r453 fix */
- MP4hFile = MP4Create(aacFileName, MP4_DETAILS_ERROR, 0);
- #else
-- MP4hFile = MP4Create(aacFileName, MP4_DETAILS_ERROR, 0, 0);
-+ MP4hFile = MP4Create(aacFileName, 0);
- #endif
- if (!MP4_IS_VALID_FILE_HANDLE(MP4hFile)) {
- fprintf(stderr, "Couldn't create output file %s\n", aacFileName);
-@@ -905,12 +907,22 @@ int main(int argc, char *argv[])
- free(ASC);
-
- /* set metadata */
-+#if HAVE_DECL_MP4TAGSALLOC
-+ const MP4Tags* tags;
-+ tags = MP4TagsAlloc();
-+ MP4TagsFetch( tags, MP4hFile );
-+#endif
- version_string = malloc(strlen(faac_id_string) + 6);
- strcpy(version_string, "FAAC ");
- strcpy(version_string + 5, faac_id_string);
-+#if !HAVE_DECL_MP4TAGSALLOC
- MP4SetMetadataTool(MP4hFile, version_string);
-+#else
-+ MP4TagsSetEncodingTool(tags, version_string);
-+#endif
- free(version_string);
-
-+#if !HAVE_DECL_MP4TAGSALLOC
- if (artist) MP4SetMetadataArtist(MP4hFile, artist);
- if (writer) MP4SetMetadataWriter(MP4hFile, writer);
- if (title) MP4SetMetadataName(MP4hFile, title);
-@@ -923,8 +935,40 @@ int main(int argc, char *argv[])
- if (comment) MP4SetMetadataComment(MP4hFile, comment);
- if (artSize) {
- MP4SetMetadataCoverArt(MP4hFile, art, artSize);
-+#else
-+ if (artist) MP4TagsSetArtist(tags, artist);
-+ if (writer) MP4TagsSetComposer(tags, writer);
-+ if (title) MP4TagsSetName(tags, title);
-+ if (album) MP4TagsSetAlbum(tags, album);
-+ if (trackno > 0) {
-+ MP4TagTrack tt;
-+ tt.index = trackno;
-+ tt.total = ntracks;
-+ MP4TagsSetTrack(tags, &tt);
-+ }
-+ if (discno > 0) {
-+ MP4TagDisk td;
-+ td.index = discno;
-+ td.total = ndiscs;
-+ MP4TagsSetDisk(tags, &td);
-+ }
-+ if (compilation) MP4TagsSetCompilation(tags, compilation);
-+ if (year) MP4TagsSetReleaseDate(tags, year);
-+ if (genre) MP4TagsSetGenre(tags, genre);
-+ if (comment) MP4TagsSetComments(tags, comment);
-+ if (artSize) {
-+ MP4TagArtwork mp4art;
-+ mp4art.data = art;
-+ mp4art.size = artSize;
-+ mp4art.type = MP4_ART_UNDEFINED; // delegate typing to libmp4v2
-+ MP4TagsAddArtwork( tags, &mp4art );
-+#endif
- free(art);
- }
-+#if HAVE_DECL_MP4TAGSALLOC
-+ MP4TagsStore( tags, MP4hFile );
-+ MP4TagsFree( tags );
-+#endif
- }
- else
- {
-@@ -1141,11 +1185,19 @@ int main(int argc, char *argv[])
- /* clean up */
- if (container == MP4_CONTAINER)
- {
-+#ifdef MP4_CLOSE_DO_NOT_COMPUTE_BITRATE /* r479 fix */
-+ MP4Close(MP4hFile, 0);
-+#else
- MP4Close(MP4hFile);
-+#endif
- if (optimizeFlag == 1)
- {
- fprintf(stderr, "\n\nMP4 format optimization... ");
-+#ifdef MP4_DETAILS_ERROR /* r453 fix */
- MP4Optimize(aacFileName, NULL, 0);
-+#else
-+ MP4Optimize(aacFileName, NULL);
-+#endif
- fprintf(stderr, "Done!");
- }
- } else
diff --git a/audio/faac/faac.SlackBuild b/audio/faac/faac.SlackBuild
index 5c7cec7f5d..36e0930a1e 100644
--- a/audio/faac/faac.SlackBuild
+++ b/audio/faac/faac.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for faac
# Copyright (c) 2008, Antonio Hernández Blas <hba.nihilismus@gmail.com>
+# Copyright (c) 2020, Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -26,13 +27,13 @@
# Updated to newer version by Niklas "Nille" Åkerström and also new maintainer.
PRGNAM=faac
-VERSION=${VERSION:-1.28}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-1.30}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -43,8 +44,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -57,57 +58,26 @@ else
LIBDIRSUFFIX=""
fi
-# Seems that libmp4v2 is a complicated critter. Here's how we think it works:
-#
-# libmp4v2:installed, --with-mp4v2: faac uses external libmp4v2
-# libmp4v2:not installed, --with-mp4v2: faac uses internal libmp4v2
-# libmp4v2:installed, --without-mp4v2: faac uses external libmp4v2
-# libmp4v2:not installed, --without-mp4v2: faac doesn't use any libmp4v2
-#
-# Therefore, we'll default to use --without-mp4v2, which should produce the
-# desired result in every case *except* where one wants to use the internal
-# implementation, and that creates other problems, so we don't support it.
-#
-# From what used to be in our README:
-# faac comes with its own version of libmp4v2, but if you use it, you have to
-# uninstall faac everytime you want to update it, as faac would otherwise
-# detect the already installed libmp4v2 and build against it. Then, when you
-# upgrade to the new package, it doesn't have the included libmp4v2, because
-# it was part of the old package, so faac is linking to a nonexistent library
-# after the upgrade.
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+mv $PRGNAM-$(echo $VERSION | tr . _ ) $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# http://lists.slackbuilds.org/pipermail/slackbuilds-users/2010-May/005680.html
-# Fix compilation problem faac-1.28 and external libmp4v2 1.9.1
-# see http://sourceforge.net/tracker/?func=detail&aid=2894310&group_id=704&atid=100704
-# and http://ftp.eenet.ee/gentoo-portage/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
-patch -p1 < $CWD/faac-1.28-external-libmp4v2.patch
-
-# http://sourceforge.net/p/faac/bugs/174/
-patch -p0 < $CWD/faac-1.28-libmp4v2_r479_compat.patch
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix for automake >= 1.13
-sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.in || die
+sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.ac
-# having just patched configure.in, we need to bludgeon automake
-libtoolize --force --copy
-aclocal
-autoconf
-automake --add-missing
+./bootstrap
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -117,7 +87,6 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--enable-shared=yes \
--enable-static=no \
- --without-mp4v2 \
--build=$ARCH-slackware-linux
make
@@ -127,18 +96,12 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $(find $PKG/usr/man -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README TODO docs/* \
+cp -a AUTHORS ChangeLog COPYING NEWS README TODO docs/*.{html,pdf} \
$PKG/usr/doc/$PRGNAM-$VERSION
-rm -f $PKG/usr/doc/$PRGNAM-$VERSION/faac.1
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-
-if [ "$1" = "--cleanup" ]; then
- rm -rf $PKG $TMP/$PRGNAM-$VERSION
-fi
diff --git a/audio/faac/faac.info b/audio/faac/faac.info
index a1776d7fe1..f9d907070a 100644
--- a/audio/faac/faac.info
+++ b/audio/faac/faac.info
@@ -1,10 +1,10 @@
PRGNAM="faac"
-VERSION="1.28"
+VERSION="1.30"
HOMEPAGE="https://sourceforge.net/projects/faac"
-DOWNLOAD="https://downloads.sourceforge.net/faac/faac-1.28.tar.bz2"
-MD5SUM="c5dde68840cefe46532089c9392d1df0"
+DOWNLOAD="https://github.com/knik0/faac/archive/1_30/faac-1.30.tar.gz"
+MD5SUM="8d61e6d55088e599aa91532d5e6995b0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="libmp4v2"
+REQUIRES=""
MAINTAINER="Matteo Bernardini"
EMAIL="ponce@slackbuilds.org"