summaryrefslogtreecommitdiffstats
path: root/audio/zynaddsubfx/zynaddsubfx.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/zynaddsubfx/zynaddsubfx.SlackBuild')
-rw-r--r--audio/zynaddsubfx/zynaddsubfx.SlackBuild103
1 files changed, 74 insertions, 29 deletions
diff --git a/audio/zynaddsubfx/zynaddsubfx.SlackBuild b/audio/zynaddsubfx/zynaddsubfx.SlackBuild
index 4f24d57fae..9e37de1c84 100644
--- a/audio/zynaddsubfx/zynaddsubfx.SlackBuild
+++ b/audio/zynaddsubfx/zynaddsubfx.SlackBuild
@@ -1,31 +1,56 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for ZynAddSubFX
-# Written by Arik Miller ad423520 at hotmail dot com
-
+# Written by Arik Miller
# Modified by SlackBuilds.org
+# Copyright 2020 - 2022 Johannes Schoepfer, Germany
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=zynaddsubfx
-VERSION=${VERSION:-2.5.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.0.6}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -44,7 +69,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -53,8 +78,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fixup for glibc-2.23 and/or gcc-5.3.0
-sed -i -e 's/isnan/std::isnan/' src/DSP/FFTwrapper.h
+# don't use bash completion
+sed -i \
+ -e '/add_subdirectory(bash-completion)/d' \
+ doc/CMakeLists.txt
mkdir -p build
cd build
@@ -62,39 +89,48 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DDefaultOutput=jack \
- -DDefaultInput=jack \
- -DGuiModule=fltk \
- -DCMAKE_BUILD_TYPE=Release ..
+ -DPluginLibDir=/usr/lib$LIBDIRSUFFIX \
+ -DCMAKE_BUILD_TYPE=Release \
+ -Wno-dev \
+ ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-( cd ExternalPrograms/Spliter
+mkdir -p $PKG/usr/share/icons/hicolor/scalable/apps/
+mv $PKG/usr/share/pixmaps/$PRGNAM.svg $PKG/usr/share/icons/hicolor/scalable/apps/
+mv $PRGNAM.ico $PKG/usr/share/pixmaps
+
+cd ExternalPrograms/Spliter
make
cp -a spliter $PKG/usr/bin
-)
+cd ../..
-( cd ExternalPrograms/Controller
+cd ExternalPrograms/Controller
sed -i "s|Box\.h|Box\.H|" ControllerUI.fl
make
cp -a controller $PKG/usr/bin
-)
+cd ../..
+
+cd doc
+ a2x --doctype manpage --format manpage zynaddsubfx.1.txt
+ mkdir -p $PKG/usr/man/man1
+ cat zynaddsubfx.1 > $PKG/usr/man/man1/zynaddsubfx.1
+ asciidoc -a toc zynaddsubfx.txt
+cd ..
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd doc
- make man xhtml
-)
-
-mkdir -p $PKG/usr/man/man1
-gzip -9 < doc/zynaddsubfx.1 > $PKG/usr/man/man1/zynaddsubfx.1.gz
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- COPYING ChangeLog *.txt doc/images doc/zynaddsubfx.html \
+ NEWS.txt doc/images doc/zynaddsubfx.html \
$PKG/usr/doc/$PRGNAM-$VERSION
+ cp -a $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
+ rm -rf $PKG/usr/share/doc
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -102,4 +138,13 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+if [ "${SETCAP:-yes}" = "yes" ]; then
+ for bin in $(find . -type f -exec file '{}' + | grep " ELF .* executable, " | cut -f 1 -d : ); do
+ if [ -n "$(readelf -d $bin | grep libjack.so)" ]; then
+ echo "/sbin/setcap cap_ipc_lock,cap_sys_nice=ep $bin" >> $PKG/install/doinst.sh
+ chown root:audio $PKG/$bin
+ chmod 0750 $PKG/$bin
+ fi
+ done
+fi
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE