summaryrefslogtreecommitdiffstats
path: root/audio/whipper/whipper.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/whipper/whipper.SlackBuild')
-rw-r--r--audio/whipper/whipper.SlackBuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/audio/whipper/whipper.SlackBuild b/audio/whipper/whipper.SlackBuild
index 8e63f12d24..fe6f0129c0 100644
--- a/audio/whipper/whipper.SlackBuild
+++ b/audio/whipper/whipper.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for whipper
-# Copyright 2017-2019, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2017-2022, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=whipper
-VERSION=${VERSION:-0.8.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-0.10.0}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -72,6 +69,9 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+
+patch -p1 < $CWD/543.patch
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -81,11 +81,18 @@ find -L . \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+make -C man
+mkdir -p $PKG/usr/man/man1
+mv man/*.1 $PKG/usr/man/man1
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGELOG.md COVERAGE HACKING README.md TODO \
$PKG/usr/doc/$PRGNAM-$VERSION