summaryrefslogtreecommitdiffstats
path: root/audio/vocoder/vocoder.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/vocoder/vocoder.SlackBuild')
-rw-r--r--audio/vocoder/vocoder.SlackBuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/audio/vocoder/vocoder.SlackBuild b/audio/vocoder/vocoder.SlackBuild
index 37c24dce1f..ed48fe6883 100644
--- a/audio/vocoder/vocoder.SlackBuild
+++ b/audio/vocoder/vocoder.SlackBuild
@@ -2,10 +2,11 @@
# Slackware build script for vocoder
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20211130 bkw: BUILD=3, new-style icons.
# 20170312 bkw:
# - actually use SLKCFLAGS
# - stop fluid from writing to /root/.fltk/
@@ -16,7 +17,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=vocoder
VERSION=${VERSION:-0.29}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -28,9 +29,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -63,11 +61,8 @@ rm -rf $PRGNAM
tar xvf $CWD/$PRGNAM-jack-$VERSION.tar.gz
cd $PRGNAM
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
sed -i "s,-O2,$SLKCFLAGS -include unistd.h," src/Makefile
sed -i "/^CFLAGS/s,\$, $SLKCFLAGS -include unistd.h," util/Makefile
@@ -85,8 +80,15 @@ install -s -m0755 src/$PRGNAM $PKG/usr/bin/$PRGNAM
# icon made for this slackbuild, by crudely stitching together a generic Tux
# plus http://openclipart.org/detail/24414/old-style-microphone-by-boobaloo
+for px in 16 32 48 64 128; do
+ size=${px}x${px}
+ dir=$PKG/usr/share/icons/hicolor/$size/apps
+ mkdir -p $dir
+ convert -resize $size $CWD/$PRGNAM.png $dir/$PRGNAM.png
+done
+
mkdir -p $PKG/usr/share/pixmaps
-cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
# .desktop written for this slackbuild.
mkdir -p $PKG/usr/share/applications