summaryrefslogtreecommitdiffstats
path: root/audio/qjackctl/qjackctl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/qjackctl/qjackctl.SlackBuild')
-rw-r--r--audio/qjackctl/qjackctl.SlackBuild74
1 files changed, 35 insertions, 39 deletions
diff --git a/audio/qjackctl/qjackctl.SlackBuild b/audio/qjackctl/qjackctl.SlackBuild
index 1b780f3090..af5c1eb6ce 100644
--- a/audio/qjackctl/qjackctl.SlackBuild
+++ b/audio/qjackctl/qjackctl.SlackBuild
@@ -25,6 +25,19 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20231121 bkw: update for v0.9.12, enable SETCAP=yes by default (no idea
+# why it was disabled in the first place).
+
+# 20230106 bkw: update for v0.9.9.
+# 20220614 bkw: update for v0.9.7.
+
+# 20211126 bkw:
+# - update for v0.9.5.
+# - use cmake (got reports that autotools builds don't run correctly).
+# - get rid of 14.2 french man page support.
+# - actually use SLKCFLAGS.
+# - old-style icon (symlink really).
+
# 20210306 bkw: update for v0.9.1.
# 20201218 bkw: update for v0.9.0.
@@ -36,7 +49,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=qjackctl
-VERSION=${VERSION:-0.9.1}
+VERSION=${VERSION:-0.9.12}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,9 +62,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -61,18 +71,15 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+# cmake's gotten smart enough to deduce lib/lib64, so no need for LIBDIRSUFFIX.
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
fi
set -eu
@@ -87,38 +94,27 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# 20201218 bkw: it's tripping over qt4's qmake, so force the issue:
-sed -i 's|\<qmake,|qmake-qt5,|' configure.ac
-autoreconf -if
-
-CFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-strip $PKG/usr/bin/$PRGNAM
-
-# man pages already compressed, but the French one needs a little help
-# to respect LANG=fr_FR or LANG=fr_FR.UTF-8 in the env.
-mkdir -p $PKG/usr/man/fr.UTF-8/man1 $PKG/usr/man/fr/man1
-
-# This works only for man-db (which becomes the stock man command in 15.0).
-ln -s ../../man1/$PRGNAM.fr.1.gz $PKG/usr/man/fr.UTF-8/man1/$PRGNAM.1.gz
-
-# This works for 14.2's man command, which doesn't grok the fullness of utf-8.
-iconv -f UTF-8 -t ISO-8859-1 $PRGNAM.fr.1 | \
- gzip -9c > \
- $PKG/usr/man/fr/man1/$PRGNAM.1.gz
+SLKCFLAGS+=" -DNDEBUG"
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_MANDIR=/usr/man \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make VERBOSE=1
+ make install/strip DESTDIR=$PKG
+cd ..
+
+gzip $PKG/usr/man/*/man1/* $PKG/usr/man/man1/*
+
+mkdir -p $PKG/usr/share/pixmaps
+ln -s ../icons/hicolor/32x32/apps/org.rncbc.qjackctl.png \
+ $PKG/usr/share/pixmaps/$PRGNAM.png
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog README TODO TRANSLATORS \
+cp -a ChangeLog README LICENSE \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -127,7 +123,7 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
# Only add capability stuff if not disabled:
-if [ "${SETCAP:-no}" = "yes" ]; then
+if [ "${SETCAP:-yes}" = "yes" ]; then
cat $CWD/setcap.sh >> $PKG/install/doinst.sh
# Only allow execution by audio group
chown root:audio $PKG/usr/bin/*