summaryrefslogtreecommitdiffstats
path: root/audio/puddletag/puddletag.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/puddletag/puddletag.SlackBuild')
-rw-r--r--audio/puddletag/puddletag.SlackBuild36
1 files changed, 15 insertions, 21 deletions
diff --git a/audio/puddletag/puddletag.SlackBuild b/audio/puddletag/puddletag.SlackBuild
index 34417169b2..9701822aa1 100644
--- a/audio/puddletag/puddletag.SlackBuild
+++ b/audio/puddletag/puddletag.SlackBuild
@@ -4,7 +4,7 @@
# Copyright 2012-2014 Bill Kirkpatrick, Cedar Lane, TX USA <bkirkp@gmail.com>
# Copyright 2016-2017 Philip van der Hoeven, Almere, The Netherlands
-# Copyright 2020 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
+# Copyright 2020-2024 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=puddletag
-VERSION=${VERSION:-2.0.1}
+VERSION=${VERSION:-2.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -81,9 +64,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-cd source
+# Remove hardcoded required module versions
+sed -i 's/==.*//' requirements.txt
+
+# Remove unneeded dep (not required due to Slackware's pyqt5 package)
+sed -i '/pyqt5-qt5/d' requirements.txt
+
python3 setup.py install --root=$PKG
+# Install plugins globally
+PYTHONDIR="$(python3 -c 'import sysconfig; print(sysconfig.get_paths()["purelib"])')"
+cp -r puddlestuff/plugins/* $PKG/$PYTHONDIR/puddlestuff/plugins
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -93,7 +85,9 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE MANIFEST NEWS ../README.md THANKS TODO changelog $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE NEWS README.md THANKS TODO changelog copyright \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install