summaryrefslogtreecommitdiffstats
path: root/audio/lmms/lmms.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/lmms/lmms.SlackBuild')
-rw-r--r--audio/lmms/lmms.SlackBuild30
1 files changed, 9 insertions, 21 deletions
diff --git a/audio/lmms/lmms.SlackBuild b/audio/lmms/lmms.SlackBuild
index c895d0c74a..6aeb55b098 100644
--- a/audio/lmms/lmms.SlackBuild
+++ b/audio/lmms/lmms.SlackBuild
@@ -7,13 +7,10 @@
# 20200415 bkw: modified by SlackBuilds.org
PRGNAM=lmms
-VERSION=${VERSION:-1.2.1}
+VERSION=${VERSION:-1.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# 20200415 bkw: rpmalloc version
-LIBVER=${LIBVER:-20190202_d9b5ee0}
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -46,23 +43,13 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-
-# 20200415 bkw: upstream didn't bother to include rpmalloc in their
-# release tarball. The lmms build system is set up to expect rpmalloc
-# source, not a library in e.g. /usr/lib64, so we can't just make a
-# rpmalloc build and make it a depencency of lmms. Furthermore, we can't
-# just use an autogenerated github tarball, as it doesn't contain the
-# CMakeLists.txt required by lmms. The rpmalloc source here came from
-# the rpmalloc submodule from a git clone of lmms.
-cd src/3rdparty
- rm -rf rpmalloc
- tar xvf $CWD/rpmalloc-$LIBVER.tar.?z
- # mv rpmalloc-$LIBVER rpmalloc # only need for rpmalloc releases
-cd -
-
+rm -rf $PRGNAM
+tar xvf $CWD/${PRGNAM}_$VERSION.tar.?z
+cd $PRGNAM
+# Fix symlink
+( cd plugins/carlabase/carla/bin/carla.lv2
+ rm resources
+ ln -s ../../resources . )
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,6 +67,7 @@ cd build
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
-DBASHCOMP_PKG_PATH=$PKG/usr/share/bash-completion/completions \
+ -DWANT_QT5=1 \
..
make VERBOSE=1
make install DESTDIR=$PKG