summaryrefslogtreecommitdiffstats
path: root/audio/lash
diff options
context:
space:
mode:
Diffstat (limited to 'audio/lash')
-rw-r--r--audio/lash/README10
-rw-r--r--audio/lash/lash.SlackBuild55
-rw-r--r--audio/lash/lash.info6
-rw-r--r--audio/lash/slack-desc4
4 files changed, 49 insertions, 26 deletions
diff --git a/audio/lash/README b/audio/lash/README
index 90d52868ff..8075e1f4ba 100644
--- a/audio/lash/README
+++ b/audio/lash/README
@@ -1,4 +1,8 @@
LASH is a session management system for GNU/Linux audio applications.
-It allows you to save and restore audio sessions consisting of
-multiple interconneced applications, restoring program state (ie
-loaded patches) and the connections between them.
+It allows you to save and restore audio sessions consisting of multiple
+interconnected applications, restoring program state (i.e. loaded
+patches) and the connections between them.
+
+OPTIONAL:
+
+texi2html is required to build the HTML manual.
diff --git a/audio/lash/lash.SlackBuild b/audio/lash/lash.SlackBuild
index 0918bdd95d..1279c3129a 100644
--- a/audio/lash/lash.SlackBuild
+++ b/audio/lash/lash.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for lash
-# Copyright 20092012 David Woodfall <dave@dawoodfall.net>
+# Copyright 20092012 David Woodfall <dave@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,27 +24,37 @@
# YOUR DATA IS DESTROYED, YOUR HOUSE BURNS DOWN OR YOUR DOG RUNS OFF.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=lash
VERSION=${VERSION:-0.6.0.594}
SOURCE=$PRGNAM-0.6.0~rc2
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-6}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,16 +77,23 @@ tar xvf $CWD/$SOURCE.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-if [ "$(/usr/share/texmf/bin/texi2html --version)" != "1.76" ]; then
- patch -p1 --verbose < $CWD/texlive.patch
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+#if [ "$(/usr/share/texmf/bin/texi2html --version 2>/dev/null)" != "1.76" ]; then
+# patch -p1 --verbose < $CWD/texlive.patch
+#fi
+
+if [ -x /usr/bin/texi2html ]; then
+ manual=docs/lash-manual-html-one-page/lash-manual.html
+ sed -i "s,texi2html --number,&-sections,g" docs/Makefile.in
fi
-CFLAGS="$SLKCFLAGS" \
+export LDFLAGS="-ldl -lm -ltirpc"
+
+CFLAGS="$SLKCFLAGS -I/usr/include/tirpc" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -91,17 +108,19 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp AUTHORS README.SECURITY COPYING ChangeLog ChangeLog.old NEWS INSTALL README \
- docs/lash-manual-html-one-page/lash-manual.html \
+ $manual \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+rm -f $PKG/usr/lib*/*.la
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/lash/lash.info b/audio/lash/lash.info
index deee38c2e2..3228ba3e88 100644
--- a/audio/lash/lash.info
+++ b/audio/lash/lash.info
@@ -5,6 +5,6 @@ DOWNLOAD="http://download.savannah.gnu.org/releases/lash/lash-0.6.0~rc2.tar.bz2"
MD5SUM="af1dc4f4ceb284b1b0845de4f4c2fe47"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="jack-audio-connection-kit"
-MAINTAINER="David Woodfall"
-EMAIL="dave@dawoodfall.net"
+REQUIRES="jack"
+MAINTAINER="D Woodfall"
+EMAIL="dave@slackbuilds.org"
diff --git a/audio/lash/slack-desc b/audio/lash/slack-desc
index 797ba2331c..076a1cd802 100644
--- a/audio/lash/slack-desc
+++ b/audio/lash/slack-desc
@@ -10,10 +10,10 @@ lash: lash (audio session management system)
lash:
lash: LASH is a session management system for GNU/Linux audio applications.
lash: It allows you to save and restore audio sessions consisting of
-lash: multiple interconneced applications, restoring program state (ie
+lash: multiple interconnected applications, restoring program state (i.e.
lash: loaded patches) and the connections between them.
lash:
-lash: Slackbuild by David Woodfall
+lash: http://savannah.nongnu.org/projects/lash
lash:
lash:
lash: