summaryrefslogtreecommitdiffstats
path: root/audio/jaaa/jaaa.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/jaaa/jaaa.SlackBuild')
-rw-r--r--audio/jaaa/jaaa.SlackBuild45
1 files changed, 33 insertions, 12 deletions
diff --git a/audio/jaaa/jaaa.SlackBuild b/audio/jaaa/jaaa.SlackBuild
index 2bb62dbb9e..d39219ac7d 100644
--- a/audio/jaaa/jaaa.SlackBuild
+++ b/audio/jaaa/jaaa.SlackBuild
@@ -1,15 +1,20 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for jaaa
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20211129 bkw: BUILD=2, new-style icons, expand man page.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=jaaa
-VERSION=${VERSION:-0.8.4}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-0.9.2}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -19,7 +24,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -47,11 +56,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
sed -i \
@@ -60,6 +66,9 @@ if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
source/Makefile
fi
+# where does "pkgconf" come from?
+sed -i 's,pkgconf,pkg-config,' source/Makefile
+
make -C source $PRGNAM install PREFIX=/usr DESTDIR=$PKG
strip $PKG/usr/bin/$PRGNAM
@@ -67,9 +76,21 @@ mkdir -p $PKG/usr/man/man1
gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
mkdir -p $PKG/usr/share/applications
-cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+for i in $PRGNAM $PRGNAM-alsa; do
+ cat $CWD/$i.desktop > $PKG/usr/share/applications/$i.desktop
+done
+
+# the 32x32 icon comes from Debian.
+# the 48x48 icon is the 32x32 one, centered in a 48x48 transparent PNG.
+mkdir -p $PKG/usr/share/icons/hicolor/{32x32,48x48}/apps
+convert $CWD/$PRGNAM.xpm \
+ $PKG/usr/share/icons/hicolor/32x32/apps/$PRGNAM.png
+convert -background none -extent 48x48 -gravity center \
+ $CWD/$PRGNAM.xpm \
+ $PKG/usr/share/icons/hicolor/48x48/apps/$PRGNAM.png
mkdir -p $PKG/usr/share/pixmaps
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
cat $CWD/$PRGNAM.xpm > $PKG/usr/share/pixmaps/$PRGNAM.xpm
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
@@ -89,4 +110,4 @@ if [ "${SETCAP:-yes}" = "yes" ]; then
fi
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE