summaryrefslogtreecommitdiffstats
path: root/academic/veusz
diff options
context:
space:
mode:
Diffstat (limited to 'academic/veusz')
-rw-r--r--academic/veusz/veusz.SlackBuild19
-rw-r--r--academic/veusz/veusz.info2
2 files changed, 15 insertions, 6 deletions
diff --git a/academic/veusz/veusz.SlackBuild b/academic/veusz/veusz.SlackBuild
index b11846a622..0687b9c384 100644
--- a/academic/veusz/veusz.SlackBuild
+++ b/academic/veusz/veusz.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for veusz
# Based on Slackware 14.2 SlackBuild and Andrea Sciucca's SlackBuild for veusz
#
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=veusz
VERSION=${VERSION:-3.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,8 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-PYTHONVER=$(python -V 2>&1 | cut -f 2 -d' ' | cut -f 1-2 -d.)
-export SIP_EXE=/usr/bin/python3-sip
+export SIP_EXE=/usr/bin/sip3
python3 setup.py install --root $PKG
@@ -108,4 +117,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/veusz/veusz.info b/academic/veusz/veusz.info
index eac4b5be7a..4b02fb8b23 100644
--- a/academic/veusz/veusz.info
+++ b/academic/veusz/veusz.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/veusz/veusz/releases/download/veusz-3.3.1/veusz-3.3
MD5SUM="1c7d42d6f87ea3b98fafc8dc52dbbc58"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="numpy3 python3-PyQt5"
+REQUIRES="python3-numpy"
MAINTAINER="Fellype do Nascimento"
EMAIL="fellype (at) gmail (dot) com"