summaryrefslogtreecommitdiffstats
path: root/academic/veusz/veusz.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/veusz/veusz.SlackBuild')
-rw-r--r--academic/veusz/veusz.SlackBuild33
1 files changed, 22 insertions, 11 deletions
diff --git a/academic/veusz/veusz.SlackBuild b/academic/veusz/veusz.SlackBuild
index f3e607ab95..0687b9c384 100644
--- a/academic/veusz/veusz.SlackBuild
+++ b/academic/veusz/veusz.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for veusz
# Based on Slackware 14.2 SlackBuild and Andrea Sciucca's SlackBuild for veusz
#
-# Copyright 2016-2019, Fellype do Nascimento, Campinas - Brazil
+# Copyright 2016-2020, Fellype do Nascimento, Guaratingueta - Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=veusz
-VERSION=${VERSION:-3.1}
+VERSION=${VERSION:-3.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,17 +79,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-PYTHONVER=$(python -V 2>&1 | cut -f 2 -d' ' | cut -f 1-2 -d.)
-export SIP_EXE=/usr/bin/python2-sip
-export SIP_INCLUDE_DIR="/usr/include/python$PYTHONVER/python2-sip"
+export SIP_EXE=/usr/bin/sip3
-python setup.py install --root $PKG
+python3 setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING INSTALL README VERSION $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog COPYING INSTALL README.md VERSION $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cp Documents/manual/pdf/veusz.pdf $PKG/usr/doc/$PRGNAM-$VERSION
@@ -94,8 +102,11 @@ done
install -m 644 -p -D veusz.svg $PKG/usr/share/icons/hicolor/scalable/apps/veusz.svg
cd -
-# Installing desktop menu file
+# Install support files
install -m 644 -p -D support/veusz.desktop $PKG/usr/share/applications/veusz.desktop
+install -m 644 -p -D support/veusz.appdata.xml $PKG/usr/share/appdata/veusz.appdata.xml
+install -m 644 -p -D support/veusz.xml $PKG/usr/share/mime/packages/veusz.xml
+
mkdir -p $PKG/usr/man/man1
gzip Documents/man-page/veusz.1 > $PKG/usr/man/man1/veusz.1.gz
@@ -106,4 +117,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE