summaryrefslogtreecommitdiffstats
path: root/academic/sundials/sundials.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/sundials/sundials.SlackBuild')
-rw-r--r--academic/sundials/sundials.SlackBuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/academic/sundials/sundials.SlackBuild b/academic/sundials/sundials.SlackBuild
index 67f7922291..3fb0a5fab5 100644
--- a/academic/sundials/sundials.SlackBuild
+++ b/academic/sundials/sundials.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for sundials
@@ -24,10 +24,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=sundials
-VERSION=${VERSION:-3.1.1}
+VERSION=${VERSION:-5.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -37,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -82,6 +92,8 @@ sed -i \
src/*/CMakeLists.txt \
src/*/*/CMakeLists.txt
+export PATH=/opt/cmake-202x/bin:$PATH
+
mkdir -p build
cd build
cmake \
@@ -108,4 +120,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE