summaryrefslogtreecommitdiffstats
path: root/academic/scipy
diff options
context:
space:
mode:
Diffstat (limited to 'academic/scipy')
-rw-r--r--academic/scipy/README4
-rw-r--r--academic/scipy/scipy.SlackBuild20
-rw-r--r--academic/scipy/scipy.info6
3 files changed, 20 insertions, 10 deletions
diff --git a/academic/scipy/README b/academic/scipy/README
index 7275306452..1c3400ed17 100644
--- a/academic/scipy/README
+++ b/academic/scipy/README
@@ -11,6 +11,4 @@ some of the world's leading scientists and engineers.
umfpack is an optional dependency. matplotlib and ipython are nice to
have in connection with scipy, but scipy does not depend on them.
-NOTE: Presently, if you install umfpack and its dependencies before
-scipy, make sure there is a link to /usr/include/amd/amd.h from within
-/usr/include/umfpack, otherwise scipy will not build.
+If you need to build scipy for debugging, set DEBUG=y.
diff --git a/academic/scipy/scipy.SlackBuild b/academic/scipy/scipy.SlackBuild
index c373bb9fe2..48e6c263bc 100644
--- a/academic/scipy/scipy.SlackBuild
+++ b/academic/scipy/scipy.SlackBuild
@@ -4,10 +4,11 @@
# Written by Eugene Suter <easuter@gmail.com>
# Updated to 0.7.2 by João Felipe Santos <joao.eel@gmail.com>
-# Updated to 0.9.0 by Serban Udrea <S.Udrea@gsi.de>
+# Updated up to 0.10.1 by Serban Udrea <S.Udrea@gsi.de>
+# Added support for building with debugging symbols (S. Udrea)
PRGNAM=scipy
-VERSION=${VERSION:-0.9.0}
+VERSION=${VERSION:-0.10.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,10 +40,21 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root $PKG
+DEBUG=${DEBUG:-no}
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+case "$DEBUG" in
+ [yY]|[yY][eE][sS]) DEBUG="y" ;;
+ *) DEBUG="" ;;
+esac
+
+if [ ! "$DEBUG" ]; then
+ python setup.py install --root $PKG
+ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+else
+ python setup.py build --debug
+ python setup.py install --root $PKG
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE.txt README.txt THANKS.txt TOCHANGE.txt \
diff --git a/academic/scipy/scipy.info b/academic/scipy/scipy.info
index fbaae126d8..c56fb88d72 100644
--- a/academic/scipy/scipy.info
+++ b/academic/scipy/scipy.info
@@ -1,8 +1,8 @@
PRGNAM="scipy"
-VERSION="0.9.0"
+VERSION="0.10.1"
HOMEPAGE="http://www.scipy.org/"
-DOWNLOAD="http://garr.dl.sourceforge.net/project/scipy/scipy/0.9.0/scipy-0.9.0.tar.gz"
-MD5SUM="ebfef6e8e82d15c875a4ee6a46d4e1cd"
+DOWNLOAD="http://downloads.sourceforge.net/scipy/scipy-0.10.1.tar.gz"
+MD5SUM="6ad976549e22e04ca93e70cf55b70a22"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="lapack numpy"