summaryrefslogtreecommitdiffstats
path: root/academic/scipy/scipy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/scipy/scipy.SlackBuild')
-rw-r--r--academic/scipy/scipy.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/academic/scipy/scipy.SlackBuild b/academic/scipy/scipy.SlackBuild
index d317dd0478..043194c101 100644
--- a/academic/scipy/scipy.SlackBuild
+++ b/academic/scipy/scipy.SlackBuild
@@ -30,7 +30,7 @@
PRGNAM=scipy
VERSION=${VERSION:-1.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -63,12 +63,10 @@ find -L . \
-exec chmod 644 {} \;
DEBUG=${DEBUG:-no}
-case "$DEBUG" in
- [yY]|[yY][eE][sS]) DEBUG="y" ;;
- *) DEBUG="" ;;
-esac
+DEBUG=$(echo "$DEBUG"|cut -b 1|tr a-z A-Z)
-if [ ! "$DEBUG" ]; then
+if [ "$DEBUG" = "N" ]
+then
python setup.py install --root $PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true