summaryrefslogtreecommitdiffstats
path: root/academic/scipy/scipy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/scipy/scipy.SlackBuild')
-rw-r--r--academic/scipy/scipy.SlackBuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/academic/scipy/scipy.SlackBuild b/academic/scipy/scipy.SlackBuild
index c373bb9fe2..48e6c263bc 100644
--- a/academic/scipy/scipy.SlackBuild
+++ b/academic/scipy/scipy.SlackBuild
@@ -4,10 +4,11 @@
# Written by Eugene Suter <easuter@gmail.com>
# Updated to 0.7.2 by João Felipe Santos <joao.eel@gmail.com>
-# Updated to 0.9.0 by Serban Udrea <S.Udrea@gsi.de>
+# Updated up to 0.10.1 by Serban Udrea <S.Udrea@gsi.de>
+# Added support for building with debugging symbols (S. Udrea)
PRGNAM=scipy
-VERSION=${VERSION:-0.9.0}
+VERSION=${VERSION:-0.10.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,10 +40,21 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root $PKG
+DEBUG=${DEBUG:-no}
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+case "$DEBUG" in
+ [yY]|[yY][eE][sS]) DEBUG="y" ;;
+ *) DEBUG="" ;;
+esac
+
+if [ ! "$DEBUG" ]; then
+ python setup.py install --root $PKG
+ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+else
+ python setup.py build --debug
+ python setup.py install --root $PKG
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE.txt README.txt THANKS.txt TOCHANGE.txt \