summaryrefslogtreecommitdiffstats
path: root/academic/scidavis
diff options
context:
space:
mode:
Diffstat (limited to 'academic/scidavis')
-rw-r--r--academic/scidavis/README12
-rw-r--r--academic/scidavis/scidavis.SlackBuild91
-rw-r--r--academic/scidavis/scidavis.info16
3 files changed, 69 insertions, 50 deletions
diff --git a/academic/scidavis/README b/academic/scidavis/README
index a9cfc5d263..3f0de3cf1c 100644
--- a/academic/scidavis/README
+++ b/academic/scidavis/README
@@ -7,13 +7,5 @@ features such as scriptability and extensibility.
SciDAVis started as a fork of QtiPlot.
-Optional dependencies, after installation, are scipy and pygsl (to
-improve python scripting).
-
-Note for Slackware-current
-
-Since version 1.23 it is possible to build/use SciDAVis with Python 3
-- just use PYTHON3=yes before executing scidavis.SlackBuild. Default is
-to use python 2 (PYTHON3=no).
-*** It does not build using Python 3 in Slackware 14.2 or previous
-because the shipped PyQt was not built with Python 3 support. ***
+Optional dependencies at runtime are scipy and pygsl (to improve
+python scripting)
diff --git a/academic/scidavis/scidavis.SlackBuild b/academic/scidavis/scidavis.SlackBuild
index a6d3f7b75a..6ebdd91a51 100644
--- a/academic/scidavis/scidavis.SlackBuild
+++ b/academic/scidavis/scidavis.SlackBuild
@@ -1,9 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for SciDAVis
-# Based on the Slackware 14.2 SlackBuild
+# Based on the Slackware 15.0 SlackBuild
#
-# Copyright 2017-2019, Fellype do Nascimento, Campinas - Brazil
+# Copyright 2017-2022, Fellype do Nascimento, Guaratingueta - Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=scidavis
-VERSION=${VERSION:-1.26}
+VERSION=${VERSION:-2.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,20 +39,30 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- SPEC=""
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- SPEC=""
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- SPEC="-spec linux-g++-64"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
rm -rf $PKG
@@ -58,6 +71,18 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+
+rmdir 3rdparty/qwt5-qt5/
+rmdir 3rdparty/qwtplot3d/
+rmdir 3rdparty/liborigin/
+
+tar xvf $CWD/qwt5-qt5-f7519200f102676fb04fb7bd0be555e0a419d378.tar.gz -C 3rdparty/
+mv 3rdparty/qwt5-qt5-f7519200f102676fb04fb7bd0be555e0a419d378 3rdparty/qwt5-qt5
+tar xvf $CWD/qwtplot3d-b2655743d30ed3185f3c0e2626b33a1d29655216.tar.gz -C 3rdparty/
+mv 3rdparty/qwtplot3d-b2655743d30ed3185f3c0e2626b33a1d29655216 3rdparty/qwtplot3d
+tar xvf $CWD/liborigin-a92f26f28e531f64684b66a2731dd617bea3cb45.tar.gz -C 3rdparty/
+mv 3rdparty/liborigin-a92f26f28e531f64684b66a2731dd617bea3cb45 3rdparty/liborigin
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -65,45 +90,41 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Correct the manpage path
-sed -i -e 's#share/man#man#' scidavis/scidavis.pro
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
-# Since version 1.23 it is possible to build/use SciDAVis with Python 3 - just use
-# PYTHON3=yes before execute scidavis.SlackBuild. Default is to use python 2 (PYTHON3=no).
-# *** It does not build using Python 3 in Slackware 14.2 or previous because PyQt was not built with
-# Python 3 support. I'm adding this here because I know it will be useful in the future and for the
-# tests currently done in -current
-if [ "${PYTHON3:-no}" = "yes" ]; then
- export PYTHON=python3
-else
- export PYTHON=python2
-fi
+# Set the correct python paths - code based on scidavis.spec for Fedora by Alexander Ploumistos
+sed -i "s:set(PYTHON_SCRIPTDIR etc:set(PYTHON_SCRIPTDIR lib$LIBDIRSUFFIX/python$PYVER/site-packages/scidavis:" scidavis/CMakeLists.txt
+sed -i "s:FILES scidavisrc.py \${CMAKE_CURRENT_BINARY_DIR}/\$<CONFIG>/scidavisrc.pyc DESTINATION:FILES scidavisrc.py DESTINATION:" scidavis/CMakeLists.txt
+sed -i "s:FILES scidavisrc.py \${CMAKE_CURRENT_BINARY_DIR}/scidavisrc.pyc DESTINATION:FILES scidavisrc.py DESTINATION:" scidavis/CMakeLists.txt
+sed -i "s:FILES scidavisUtil.py DESTINATION share/scidavis:FILES scidavisUtil.py DESTINATION \${PYTHON_SCRIPTDIR}:" scidavis/CMakeLists.txt
+sed -i "s:PYTHON_CONFIG_PATH=\"\${CMAKE_INSTALL_PREFIX}/etc\":PYTHON_CONFIG_PATH=\"/usr/lib$LIBDIRSUFFIX/python$PYVER/site-packages/scidavis\":" libscidavis/CMakeLists.txt
+sed -i "s:PYTHON_UTIL_PATH=\"\${CMAKE_INSTALL_PREFIX}/share/scidavis\":PYTHON_UTIL_PATH=\"/usr/lib$LIBDIRSUFFIX/python$PYVER/site-packages/scidavis\":" libscidavis/CMakeLists.txt
+
+export PYTHON=python3
-## For some unknown reason, to build in Slackware we need to run qmake twice in order to get the app icons working properly
-## See https://sourceforge.net/p/scidavis/scidavis-bugs/259/
-qmake
-qmake \
- CONFIG+="liborigin python" \
- PRESET=linux_package \
- QMAKE_CFLAGS+="$SLKCFLAGS" \
- QMAKE_CXXFLAGS+="$SLKCFLAGS" \
- $SPEC
+mkdir build && cd build
+cmake .. -DSEARCH_FOR_UPDATES=OFF \
+ -DDOWNLOAD_LINKS=OFF \
+ -DORIGIN_IMPORT=ON \
+ -DSCRIPTING_PYTHON=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ..
make
-make install INSTALL_ROOT=$PKG
+make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-## Sometimes 'make install' fails to install the translation files
-mkdir -p $PKG/usr/share/scidavis/translations
-install -m 0644 scidavis/translations/*.qm $PKG/usr/share/scidavis/translations
+# Move manpage to a more appropriated dir
+mkdir -p $PKG/usr/man/man1/
+mv $PKG/usr/share/man/man1/scidavis.1 $PKG/usr/man/man1/scidavis.1
+rm -rf $PKG/usr/share/man/
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $PKG/usr/share/doc/scidavis/*.* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
rm -rf $PKG/usr/share/doc
@@ -113,4 +134,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/scidavis/scidavis.info b/academic/scidavis/scidavis.info
index 526fd3b7f9..7904927c3f 100644
--- a/academic/scidavis/scidavis.info
+++ b/academic/scidavis/scidavis.info
@@ -1,10 +1,16 @@
PRGNAM="scidavis"
-VERSION="1.26"
+VERSION="2.9.0"
HOMEPAGE="http://scidavis.sourceforge.net/"
-DOWNLOAD="https://ufpr.dl.sourceforge.net/project/scidavis/SciDAVis/1.26/scidavis-1.26.tar.gz"
-MD5SUM="a3e6158c9607dbbaab193941836259bf"
+DOWNLOAD="https://github.com/SciDAVis/scidavis/archive/2.9.0/scidavis-2.9.0.tar.gz \
+ https://github.com/SciDAVis/qwt5-qt5/archive/f751920/qwt5-qt5-f7519200f102676fb04fb7bd0be555e0a419d378.tar.gz \
+ https://github.com/SciDAVis/qwtplot3d/archive/b265574/qwtplot3d-b2655743d30ed3185f3c0e2626b33a1d29655216.tar.gz \
+ https://github.com/SciDAVis/liborigin/archive/a92f26f/liborigin-a92f26f28e531f64684b66a2731dd617bea3cb45.tar.gz"
+MD5SUM="fc80267e26c4ba75490d7baa9dfdf93f \
+ da7c360266e318948919ab2ddc8a2c4b \
+ aefa1c98e1a0df67418304b66d810b3d \
+ 8baa9dffeacc1fedeb94ffa8d35eae2c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="muParser qwt5 qwtplot3d"
+REQUIRES="muParser"
MAINTAINER="Fellype do Nascimento"
-EMAIL="fellype(at)gmail.com"
+EMAIL="fellype (at) gmail (dot) com"