summaryrefslogtreecommitdiffstats
path: root/academic/rpy2
diff options
context:
space:
mode:
Diffstat (limited to 'academic/rpy2')
-rw-r--r--academic/rpy2/README24
-rw-r--r--academic/rpy2/Rlibs.conf2
-rw-r--r--academic/rpy2/doinst.sh2
-rw-r--r--academic/rpy2/rpy2.SlackBuild124
-rw-r--r--academic/rpy2/rpy2.info10
-rw-r--r--academic/rpy2/slack-desc19
6 files changed, 181 insertions, 0 deletions
diff --git a/academic/rpy2/README b/academic/rpy2/README
new file mode 100644
index 0000000000..3685736766
--- /dev/null
+++ b/academic/rpy2/README
@@ -0,0 +1,24 @@
+Python interface to the R language.
+
+rpy2 is running an embedded R, providing access to it
+from Python using R's own C-API through either:
+
+1) a high-level interface making R functions and objects
+just like Python functions and providing a seamless
+conversion to numpy and pandas data structures
+
+2) a low-level interface closer to the C-API
+
+It is also providing features for when working with
+jupyter notebooks or ipython.
+
+NOTE:
+R needs to be compiled with the shared library flag,
+thus: build R on SBo with R_SHLIB=yes and BLAS_SHLIB=yes
+(See also the notes in the rpy2.Slackbuild)
+
+Remove installed rpy2 before building and upgrading to a new version.
+
+
+home:https://rpy2.github.io/
+documentation:https://rpy2.github.io/doc/latest/html/index.html
diff --git a/academic/rpy2/Rlibs.conf b/academic/rpy2/Rlibs.conf
new file mode 100644
index 0000000000..cd1ea265b7
--- /dev/null
+++ b/academic/rpy2/Rlibs.conf
@@ -0,0 +1,2 @@
+##placed as rpy2 cannot load R without "export LD_LIBRARY_PATH=/usr/lib64/R/lib/"
+/usr/lib64/R/lib \ No newline at end of file
diff --git a/academic/rpy2/doinst.sh b/academic/rpy2/doinst.sh
new file mode 100644
index 0000000000..bf984ccfe4
--- /dev/null
+++ b/academic/rpy2/doinst.sh
@@ -0,0 +1,2 @@
+#load the path to the R libraries to enable linking
+ldconfig
diff --git a/academic/rpy2/rpy2.SlackBuild b/academic/rpy2/rpy2.SlackBuild
new file mode 100644
index 0000000000..ea640b1291
--- /dev/null
+++ b/academic/rpy2/rpy2.SlackBuild
@@ -0,0 +1,124 @@
+#!/bin/bash
+#
+# SlackBuild for rpy2
+#
+# Copyright 2020-2024 Rob van Nues (sborg63@disroot.org)
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=rpy2
+VERSION=${VERSION:-3.5.16}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+## make sure there is R
+if ! [ -x "$(command -v R)" ]; then
+ echo 'Error: R is not installed.' >&2
+ exit 1
+fi
+
+## make sure that R has been compiled with
+## --enable-R-shlib
+## --enable-BLAS-shlib
+RHOMLIB=$(R RHOME)
+echo Found R libs:
+echo $RHOMLIB/lib/*
+
+if ! [ "$(readelf -h $RHOMLIB/lib/libR*.so | grep DYN)" ]; then
+ echo "Error: R is not compiled with shared libraries." >&2
+ exit 1
+fi
+
+## this removes an error message from setup.py
+## https://github.com/rpy2/rpy2/issues/675
+export LD_LIBRARY_PATH="${RHOMLIB}/lib:${LD_LIBRARY_PATH}"
+echo "LD_LIBRARY_PATH set to ${LD_LIBRARY_PATH}"
+
+# replace deprecated `python3 setup.py build install --root=$PKG`
+# thanks to fourtysixandtwo
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS gpl-2.0.txt NEWS README* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+## to facilitate dynamic linking with R,
+## libR.so and libRblas.so still need to be found
+## https://github.com/rpy2/rpy2/issues/675
+mkdir -p $PKG/etc/ld.so.conf.d/
+cat $CWD/Rlibs.conf > $PKG/etc/ld.so.conf.d/Rlibs.conf
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/rpy2/rpy2.info b/academic/rpy2/rpy2.info
new file mode 100644
index 0000000000..2c3adced95
--- /dev/null
+++ b/academic/rpy2/rpy2.info
@@ -0,0 +1,10 @@
+PRGNAM="rpy2"
+VERSION="3.5.16"
+HOMEPAGE="https://rpy2.github.io/"
+DOWNLOAD="https://pypi.python.org/packages/source/r/rpy2/rpy2-3.5.16.tar.gz"
+MD5SUM="be5385a5547673f5b1b64e245dcd7f13"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="R cffi python3-pytest tzlocal python3-setuptools-scm-opt"
+MAINTAINER="Rob van Nues"
+EMAIL="sborg63@disroot.org"
diff --git a/academic/rpy2/slack-desc b/academic/rpy2/slack-desc
new file mode 100644
index 0000000000..4b6f260ede
--- /dev/null
+++ b/academic/rpy2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+rpy2: rpy2 (R in Python)
+rpy2:
+rpy2: rpy2 is an interface to R running embedded in a Python process.
+rpy2: The project is mature, stable, documented, and widely used
+rpy2:
+rpy2: It is also providing features for when working
+rpy2: with jupyter notebooks or ipython.
+rpy2:
+rpy2: home:https://rpy2.github.io/
+rpy2: https://rpy2.github.io/doc/latest/html/index.html
+rpy2: