summaryrefslogtreecommitdiffstats
path: root/academic/reduce-algebra/reduce-algebra.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/reduce-algebra/reduce-algebra.SlackBuild')
-rw-r--r--academic/reduce-algebra/reduce-algebra.SlackBuild40
1 files changed, 14 insertions, 26 deletions
diff --git a/academic/reduce-algebra/reduce-algebra.SlackBuild b/academic/reduce-algebra/reduce-algebra.SlackBuild
index 27ba6c5e23..04017ffa87 100644
--- a/academic/reduce-algebra/reduce-algebra.SlackBuild
+++ b/academic/reduce-algebra/reduce-algebra.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=reduce-algebra
-VERSION=${VERSION:-20161220svn3844}
+VERSION=${VERSION:-20170124svn3877}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -63,8 +63,12 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM
+rm -rf $SRCNAM ${SRCNAM}-addnl
+mkdir -p ${SRCNAM}-addnl
tar xvf $CWD/$SRCNAM.tar.gz
+tar xvf $CWD/reduce-common_${VERSION:0:4}-${VERSION:4:2}-${VERSION:6:2}_all.tgz -C ${SRCNAM}-addnl
+chown -R root:root ${SRCNAM}-addnl/usr/share/doc/reduce
+chmod -R 644 ${SRCNAM}-addnl/usr/share/doc/reduce/*
cd $SRCNAM
chown -R root:root .
find -L . \
@@ -80,20 +84,6 @@ CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" ./configure --with-psl
make
-if [ $(command -v mk4ht) ]; then
- cd doc/manual
- make
- cd ../..
- TEX4HT=yes
-else
- cat << EOF
-TeX4ht (a part of TeX Live) is not installed.
-The HTML version of the manual will not be created.
-See README for more details.
-EOF
- TEX4HT=no
-fi
-
# The Makefile has no 'install' target (yet). Let's do by hand.
# The below code is mainly based on debianbuild/reduce/debian/rules
@@ -103,25 +93,23 @@ mkdir -p \
$PKG/usr/share/reduce/{packages,fonts} \
$PKG/usr/lib$LIBDIRSUFFIX/reduce/{pslbuild/{psl,red},cslbuild/csl} \
$PKG/usr/doc/$PRGNAM-$VERSION/{breduce,manual-tex} \
+ $PKG/usr/doc/$PRGNAM-$VERSION/manual-html \
$PKG/usr/man/man1 \
$PKG/usr/share/emacs/site-lisp/reduce
-if [ "$TEX4HT" = "yes" ]; then
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/manual-html
-fi
# copy documentation files
cp -r BUGS Contributor-Release.txt DEPENDENCY_TRACKING README README.BUILDING \
csl/reduce.doc/{BINARY-LICENSE.txt,BSD-LICENSE.txt,LGPL-2.1.txt} \
- doc/manual/manual.pdf doc/projects.txt buglist/ contrib/ doc/primers/ doc/notes/ generic/texmacs/ \
+ doc/projects.txt buglist/ contrib/ doc/primers/ doc/notes/ generic/texmacs/ \
$PKG/usr/doc/$PRGNAM-$VERSION
-cp doc/manual/*.tex $PKG/usr/doc/$PRGNAM-$VERSION/manual-tex/
+cp doc/manual/* $PKG/usr/doc/$PRGNAM-$VERSION/manual-tex/
+rm -f $PKG/usr/doc/$PRGNAM-$VERSION/manual-tex/manual.pdf
cp generic/breduce/breduce.{tex,bbl,pdf} $PKG/usr/doc/$PRGNAM-$VERSION/breduce/
cp -r doc/primers/ $PKG/usr/doc/$PRGNAM-$VERSION/
-if [ "$TEX4HT" = "yes" ]; then
- cp doc/manual/{redlogo.png,manual*.html,manual*.png,manual.css} $PKG/usr/doc/$PRGNAM-$VERSION/manual-html
- for n in bild cmsy10 gnuplotex turtleeg; do cp doc/manual/${n}*.png $PKG/usr/doc/$PRGNAM-$VERSION/manual-html ; done
- cp $PKG/usr/doc/$PRGNAM-$VERSION/manual-html/manual.html $PKG/usr/doc/$PRGNAM-$VERSION/manual-html/index.html
-fi
+cp ../${SRCNAM}-addnl/usr/share/doc/reduce/{*.html,*.png,*.css} \
+ $PKG/usr/doc/$PRGNAM-$VERSION/manual-html
+zcat ../${SRCNAM}-addnl/usr/share/doc/reduce/manual.pdf.gz \
+ > $PKG/usr/doc/$PRGNAM-$VERSION/manual.pdf
chmod -R -x+X $PKG/usr/doc/$PRGNAM-$VERSION/*
# copy man files