summaryrefslogtreecommitdiffstats
path: root/academic/meme-suite/meme-suite.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/meme-suite/meme-suite.SlackBuild')
-rw-r--r--academic/meme-suite/meme-suite.SlackBuild73
1 files changed, 41 insertions, 32 deletions
diff --git a/academic/meme-suite/meme-suite.SlackBuild b/academic/meme-suite/meme-suite.SlackBuild
index a21bb00ea1..e8f7f9c521 100644
--- a/academic/meme-suite/meme-suite.SlackBuild
+++ b/academic/meme-suite/meme-suite.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for meme-suite
-# Copyright 2017 Petar Petrov slackalaxy@gmail.com
+# Copyright 2017-2023 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=meme-suite
-SRCNAM=meme
-VERSION=${VERSION:-4.12.0}
+VERSION=${VERSION:-5.5.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=meme
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -60,9 +71,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf ${SRCNAM}_${VERSION}
-tar xvf $CWD/${SRCNAM}_${VERSION}.tar.gz
-cd ${SRCNAM}_${VERSION}
+rm -rf ${SRCNAM}-${VERSION}
+tar xvf $CWD/${SRCNAM}-${VERSION}.tar.gz
+cd ${SRCNAM}-${VERSION}
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -70,54 +81,52 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix a few paths
-sed -i "s:share/doc:doc/$PRGNAM-$VERSION/doc/:g" Makefile.in
-sed -i "s:share/doc:doc/$PRGNAM-$VERSION/doc/:g" doc/Makefile.*
-sed -i "s:share/doc:doc/$PRGNAM-$VERSION/doc/:g" doc/css/Makefile.*
-sed -i "s:share/doc:doc/$PRGNAM-$VERSION/doc/:g" doc/images/Makefile.*
-sed -i "s:share/doc:doc/$PRGNAM-$VERSION/doc/:g" doc/js/Makefile.*
-sed -i "s:share/doc:doc/$PRGNAM-$VERSION/doc/:g" doc/examples/Makefile.*
-sed -i "s:share/doc:doc/$PRGNAM-$VERSION/doc/:g" doc/examples/compute_prior_dist_example_output_files/Makefile.*
-sed -i "s:share/doc:doc/$PRGNAM-$VERSION/doc/:g" doc/examples/sample_opal_scripts/Makefile.*
-sed -i "s:\\$(libdir)/perl:&/vendor_perl:g" scripts/Makefile.*
-sed -i "s:\\$(libdir)/python:$(libdir)/python2.7/site-packages:g" scripts/Makefile.*
+# Change name from "meme" to "meme-suite"
+sed -i "s:PACKAGE_NAME='meme':PACKAGE_NAME='meme-suite':" configure
+
+# Do not append the package version to folder names
+find . -name "Makefile.*" -exec \
+sed -i 's:${PACKAGE_NAME}-${PACKAGE_VERSION}:${PACKAGE_NAME}:g' {} \;
+
+# Sometimes the brackets are not curly
+find . -name "Makefile.*" -exec \
+sed -i 's:$(PACKAGE_NAME)-${PACKAGE_VERSION}:$(PACKAGE_NAME):g' {} \;
+
+# Documentation should go to docdir not datadir
+sed -i 's:${datadir}/${PACKAGE_NAME}:${docdir}:g' doc/Makefile.*
+
+# Make empty folders for the databases
+mkdir -p $PKG/var/lib/$PRGNAM/{fasta_databases,gomo_databases,motif_databases,tgene_databases}
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--with-url="http://meme-suite.org" \
- --datarootdir=/usr/share/$PRGNAM/data \
- --sysconfdir=/usr/share/$PRGNAM/etc \
+ --datarootdir=/usr/share \
+ --libexecdir=/usr/libexec \
--localstatedir=/var \
+ --mandir=/usr/man \
--with-db=/var/lib/$PRGNAM \
- --with-logs=/var/log/$PRGNAM \
--with-temp=/tmp
-# CFLAGS should be specified here, otherwise they are not accepted
make CFLAGS="$SLKCFLAGS -std=gnu89"
-
-# The tests are recommended, but take quite some time. Be patient or comment out the line below.
-# Also, some tests fail on a 32bit system, therefore it is listed as unsupported. If you find a
-# fix, let me know.
-make test
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# The databases directory should contain folders for motif, gomo and fasta databases
-mkdir -p $PKG/var/lib/$PRGNAM/{motif_databases,gomo_databases,fasta_databases}
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS COPYING INSTALL README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
+cat $CWD/README.TESTS > $PKG/usr/doc/$PRGNAM-$VERSION/README.TESTS
+cat $CWD/README.DATABASES > $PKG/usr/doc/$PRGNAM-$VERSION/README.DATABASES
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE