summaryrefslogtreecommitdiffstats
path: root/academic/bibletime/bibletime.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/bibletime/bibletime.SlackBuild')
-rw-r--r--academic/bibletime/bibletime.SlackBuild39
1 files changed, 22 insertions, 17 deletions
diff --git a/academic/bibletime/bibletime.SlackBuild b/academic/bibletime/bibletime.SlackBuild
index a0c3c992fb..a25bde4b12 100644
--- a/academic/bibletime/bibletime.SlackBuild
+++ b/academic/bibletime/bibletime.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# A slackbuild script to build the BibleTime Sword frontend
@@ -26,12 +26,18 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Modified by Robert Delahunt [twinreverb[at]puresimplicity.net
-# Modified 2018 by Tim Dickson (dickson.tim@googlemail.com)
+# Modified 2018/19/20 by Tim Dickson (dickson.tim@googlemail.com)
+# Modified 20200918 by B. Watson <urchlay@slackware.uk>
+# Modified 20220412 by Tim Dickson (dickson.tim@googlemail.com)
+# updated for v3.0.3 and fix doc location by Tim Dickson (dickson.tim@googlemail.com)
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=bibletime
-VERSION=${VERSION:-2.11.2}
+VERSION=${VERSION:-3.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -41,7 +47,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -68,17 +81,8 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar -xJvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-mkdir build
-#patch CMakeLists.txt so it works with version of qt5
-# available on slackbuilds.org
-sed -i "s/VERSION 5.9/VERSION 5.7.1/g" CMakeLists.txt
+
+mkdir -p build
cd build
cmake \
-Wno-dev \
@@ -87,7 +91,8 @@ cd build
-DCMAKE_SKIP_RPATH:BOOL=ON \
-DCMAKE_C_FLAGS="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
- -DLIB_SUFFIX=$LIBDIRSUFFIX ..
+ -DBT_DOCDIR="doc/$PRGNAM-$VERSION" \
+ -DLIB_SUFFIX=$LIBDIRSUFFIX ..
make
make install DESTDIR=$PKG
cd ..
@@ -107,4 +112,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE