summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/pygame/config_unix.patch25
-rw-r--r--python/pygame/pygame.SlackBuild11
-rw-r--r--python/pygame/pygame.info6
3 files changed, 35 insertions, 7 deletions
diff --git a/python/pygame/config_unix.patch b/python/pygame/config_unix.patch
new file mode 100644
index 0000000000..d2dc980e6d
--- /dev/null
+++ b/python/pygame/config_unix.patch
@@ -0,0 +1,25 @@
+--- pygame-1.9.6/buildconfig/config_unix.py 2019-09-11 20:29:30.060515857 +0200
++++ pygame-1.9.6/buildconfig/config_unix.py.orig 2019-09-11 20:29:54.659518227 +0200
+@@ -254,14 +254,14 @@
+ for d in DEPS:
+ d.configure(incdirs, libdirs)
+
+- for d in DEPS[1:]:
+- if not d.found:
+- if "-auto" not in sys.argv and not confirm("""
+-Warning, some of the pygame dependencies were not found. Pygame can still
+-compile and install, but games that depend on those missing dependencies
+-will not run. Would you like to continue the configuration?"""):
+- raise SystemExit("Missing dependencies")
+- break
++# for d in DEPS[1:]:
++# if not d.found:
++# if "-auto" not in sys.argv and not confirm("""
++#Warning, some of the pygame dependencies were not found. Pygame can still
++#compile and install, but games that depend on those missing dependencies
++#will not run. Would you like to continue the configuration?"""):
++# raise SystemExit("Missing dependencies")
++# break
+
+ return DEPS
+
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
index 8e8ac32b3c..36c5397ee2 100644
--- a/python/pygame/pygame.SlackBuild
+++ b/python/pygame/pygame.SlackBuild
@@ -6,7 +6,7 @@
# Modified by the SlackBuilds.org project
# Maintained by Bojan Popovic (bocke@slackware-srbija.org), 2014-2017
# Contribution by B.Watson (yalhcru@gmail.com), 11 apr. 2017.
-# Copyright 2017-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2017-2019 Dimitris Zlatanidis Orestiada, Greece
#
# All rights reserved.
#
@@ -28,7 +28,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pygame
-VERSION=${VERSION:-1.9.4}
+VERSION=${VERSION:-1.9.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -75,7 +75,10 @@ find -L . \
# TLDR: Stops packaging scripts from messing with a local PyGame install.
sed -i '/^if "install"/,$d' setup.py
-python -u config.py
+# Fix warning message for missings dependencies
+patch -p1 < $CWD/config_unix.patch
+
+python -u buildconfig/config.py
CFLAGS="$SLKCFLAGS" \
python setup.py install --root=$PKG
@@ -83,7 +86,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a WHATSNEW README.rst LGPL $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst docs/LGPL $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pygame/pygame.info b/python/pygame/pygame.info
index e91231accb..be0ad31955 100644
--- a/python/pygame/pygame.info
+++ b/python/pygame/pygame.info
@@ -1,8 +1,8 @@
PRGNAM="pygame"
-VERSION="1.9.4"
+VERSION="1.9.6"
HOMEPAGE="http://www.pygame.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/b2/6b/c510f0853765eb2219ca5aa3d416d65bb0dea7cd9bb2984aea0a0e04c24d/pygame-1.9.4.tar.gz"
-MD5SUM="35123425da093da331a89ec0dcbd1ac4"
+DOWNLOAD="https://files.pythonhosted.org/packages/0f/9c/78626be04e193c0624842090fe5555b3805c050dfaa81c8094d6441db2be/pygame-1.9.6.tar.gz"
+MD5SUM="36f8817874f9e63acdf12914340b60e9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="portmidi"