summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--development/gnustep-base/gnustep-base.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/development/gnustep-base/gnustep-base.SlackBuild b/development/gnustep-base/gnustep-base.SlackBuild
index 94e6aa33c5..339400f1bf 100644
--- a/development/gnustep-base/gnustep-base.SlackBuild
+++ b/development/gnustep-base/gnustep-base.SlackBuild
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
. /usr/share/GNUstep/Makefiles/GNUstep-reset.sh
. /usr/share/GNUstep/Makefiles/GNUstep.sh
@@ -84,8 +84,8 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
-chown -R root:root $PKG/usr/lib64/GNUstep/Libraries
-chmod -R go-w $PKG/usr/lib64/GNUstep/Libraries
+chown -R root:root $PKG/usr/lib${LIBDIRSUFFIX}/GNUstep/Libraries
+chmod -R go-w $PKG/usr/lib${LIBDIRSUFFIX}/GNUstep/Libraries
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \