summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--development/codespell/codespell.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/development/codespell/codespell.SlackBuild b/development/codespell/codespell.SlackBuild
index 0c9ca40879..74ec393dc3 100644
--- a/development/codespell/codespell.SlackBuild
+++ b/development/codespell/codespell.SlackBuild
@@ -58,7 +58,8 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
# write_to directive is broken, turns out we can do without it.
sed -i '/^write_to/d' pyproject.toml
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl