summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libraries/podofo/podofo-0.9.1-unistd.patch11
-rw-r--r--libraries/podofo/podofo.SlackBuild6
2 files changed, 16 insertions, 1 deletions
diff --git a/libraries/podofo/podofo-0.9.1-unistd.patch b/libraries/podofo/podofo-0.9.1-unistd.patch
new file mode 100644
index 0000000000..5cb9ad68ae
--- /dev/null
+++ b/libraries/podofo/podofo-0.9.1-unistd.patch
@@ -0,0 +1,11 @@
+diff -up podofo-0.9.1/test/unit/TestUtils.cpp.unistd podofo-0.9.1/test/unit/TestUtils.cpp
+--- podofo-0.9.1/test/unit/TestUtils.cpp.unistd 2012-01-16 18:12:52.000000000 +0100
++++ podofo-0.9.1/test/unit/TestUtils.cpp 2012-01-16 18:13:00.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+
+ #if defined(_WIN32) || defined(_WIN64)
+ #include <windows.h>
diff --git a/libraries/podofo/podofo.SlackBuild b/libraries/podofo/podofo.SlackBuild
index 740f6ea597..83a66fd7d0 100644
--- a/libraries/podofo/podofo.SlackBuild
+++ b/libraries/podofo/podofo.SlackBuild
@@ -6,7 +6,7 @@
PRGNAM=podofo
VERSION=0.9.1
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -54,6 +54,10 @@ find . \
# Fix mandir directory.
sed -i 's|share/man|man|' CMakeLists.txt
+# Fix building with gcc-4.7.x
+# http://sourceforge.net/tracker/?func=detail&aid=3474494&group_id=154028&atid=790130
+patch -p1 < $CWD/podofo-0.9.1-unistd.patch
+
mkdir build
cd build
cmake -G "Unix Makefiles" \