summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--development/mrustc/README4
-rw-r--r--development/mrustc/mrustc.SlackBuild4
-rw-r--r--development/mrustc/mrustc.info6
3 files changed, 8 insertions, 6 deletions
diff --git a/development/mrustc/README b/development/mrustc/README
index 0a4fb047ec..d26467c96d 100644
--- a/development/mrustc/README
+++ b/development/mrustc/README
@@ -6,8 +6,8 @@ ultimate goal of being a separate re-implementation.
This slackbuild will build and package mrustc and additionally build the
official rust 1.19.0 with stdlib.
-This script may take a while to complete (around one hour a 10 core machine)
-and will require about 18GB (!) of disk space for its temporary directory. It
+This script may take a while to complete (around one hour on a 10 core machine)
+and will require about 19GB (!) of disk space for its temporary directory. It
defaults to "/tmp/SBo" and you may redefine it like this:
TMP=/your/temporary/dir ./mrustc.SlackBuild
diff --git a/development/mrustc/mrustc.SlackBuild b/development/mrustc/mrustc.SlackBuild
index 9267fa84c1..bb73d64c3f 100644
--- a/development/mrustc/mrustc.SlackBuild
+++ b/development/mrustc/mrustc.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mrustc
-GITREV=${GITREV:-173dfa9fea9e65ec49fa4def9117b01c0a485ab5}
+GITREV=${GITREV:-b5b70897015ee70d62ddda9711c256ca7c720e0f}
VERSION=${VERSION:-git$(echo "$GITREV" | sed 's/^\(.\{7\}\).*$/\1/')}
RUSTCVERSION=${RUSTCVERSION:-1.19.0}
BUILD=${BUILD:-1}
@@ -86,10 +86,12 @@ make RUSTCSRC
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
+CC=gcc \
make -f minicargo.mk
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
+CC=gcc \
make -j1 -C run_rustc
mkdir -p $PKG/usr/bin
diff --git a/development/mrustc/mrustc.info b/development/mrustc/mrustc.info
index 4e6635facb..05e388d9d5 100644
--- a/development/mrustc/mrustc.info
+++ b/development/mrustc/mrustc.info
@@ -1,11 +1,11 @@
PRGNAM="mrustc"
-VERSION="git173dfa9"
+VERSION="gitb5b7089"
HOMEPAGE="https://github.com/thepowersgang/mrustc"
DOWNLOAD="UNSUPPORTED"
MD5SUM=""
-DOWNLOAD_x86_64="https://github.com/thepowersgang/mrustc/archive/173dfa9fea9e65ec49fa4def9117b01c0a485ab5/mrustc-173dfa9fea9e65ec49fa4def9117b01c0a485ab5.tar.gz \
+DOWNLOAD_x86_64="https://github.com/thepowersgang/mrustc/archive/b5b70897015ee70d62ddda9711c256ca7c720e0f/mrustc-b5b70897015ee70d62ddda9711c256ca7c720e0f.tar.gz \
https://static.rust-lang.org/dist/rustc-1.19.0-src.tar.xz"
-MD5SUM_x86_64="76751a31931e4a03369eaa4f9b187466 \
+MD5SUM_x86_64="3d385c43c17f157c0a8b29f99d580b82 \
e9af5bb321c0cad44ea0e3e2c644ab2f"
REQUIRES=""
MAINTAINER="Andrew Clemons"