summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/Mako/Mako.SlackBuild7
-rw-r--r--python/Mako/Mako.info6
-rw-r--r--python/Mako/README2
3 files changed, 11 insertions, 4 deletions
diff --git a/python/Mako/Mako.SlackBuild b/python/Mako/Mako.SlackBuild
index 108b22589d..8c69d89852 100644
--- a/python/Mako/Mako.SlackBuild
+++ b/python/Mako/Mako.SlackBuild
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=Mako
-VERSION=${VERSION:-1.0.10}
+VERSION=${VERSION:-1.0.13}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -58,6 +58,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if python3 -c 'import sys' 2>/dev/null; then
+ python3 setup.py install --root=$PKG
+fi
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS CHANGES LICENSE README.rst doc/*.html \
$PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/Mako/Mako.info b/python/Mako/Mako.info
index 997ab339eb..e5ccf21dd7 100644
--- a/python/Mako/Mako.info
+++ b/python/Mako/Mako.info
@@ -1,8 +1,8 @@
PRGNAM="Mako"
-VERSION="1.0.10"
+VERSION="1.0.13"
HOMEPAGE="https://www.makotemplates.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/f9/93/63f78c552e4397549499169198698de23b559b52e57f27d967690811d16d/Mako-1.0.10.tar.gz"
-MD5SUM="a94d376078dda65f834ea5049a81ebb5"
+DOWNLOAD="https://files.pythonhosted.org/packages/fa/29/8016763284d8fab844224f7cc5675cb4a388ebda0eb5a403260187e48435/Mako-1.0.13.tar.gz"
+MD5SUM="ad6c7dcb5d39c99f4fdf4fec892c5dee"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="MarkupSafe"
diff --git a/python/Mako/README b/python/Mako/README
index 9fa6aa27e2..b39455cf1d 100644
--- a/python/Mako/README
+++ b/python/Mako/README
@@ -7,3 +7,5 @@ language, which refines the familiar ideas of componentized layout and
inheritance to produce one of the most straightforward and flexible
models available, while also maintaining close ties to Python calling
and scoping semantics.
+
+Python3 is an optional dependency.