summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/Markups/Markups.SlackBuild77
-rw-r--r--python/Markups/Markups.info10
-rw-r--r--python/Markups/README3
-rw-r--r--python/Markups/slack-desc19
4 files changed, 109 insertions, 0 deletions
diff --git a/python/Markups/Markups.SlackBuild b/python/Markups/Markups.SlackBuild
new file mode 100644
index 0000000000..eb1b96d8ce
--- /dev/null
+++ b/python/Markups/Markups.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/sh
+
+# Slackware build script for Markups
+
+# Copyright 2019 MDrights <psychi2009@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=Markups
+VERSION=${VERSION:-3.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="LICENSE TODO AUTHORS CHANGES README.rst"
+# html documentation is not built by default
+HTML=${HTML:-0}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --prefix=/usr --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+# Adapting to Slackware's directory layout
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/Markups/Markups.info b/python/Markups/Markups.info
new file mode 100644
index 0000000000..5fa1280cf7
--- /dev/null
+++ b/python/Markups/Markups.info
@@ -0,0 +1,10 @@
+PRGNAM="Markups"
+VERSION="3.0.0"
+HOMEPAGE="https://github.com/retext-project/pymarkups"
+DOWNLOAD="https://files.pythonhosted.org/packages/2f/35/5eda745b115048ddd7ae7e66ba49862ec9d6fd12b3cd4ff0810b9a213c10/Markups-3.0.0.tar.gz"
+MD5SUM="6a2192caf4d913c7a31419946a34538e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="MDrights"
+EMAIL="psychi2009@gmail.com"
diff --git a/python/Markups/README b/python/Markups/README
new file mode 100644
index 0000000000..2b31f9a046
--- /dev/null
+++ b/python/Markups/README
@@ -0,0 +1,3 @@
+Markups provides a wrapper around various text markup languages.
+Available by default are Markdown, reStructuredText and Textile,
+but you can easily add your own markups.
diff --git a/python/Markups/slack-desc b/python/Markups/slack-desc
new file mode 100644
index 0000000000..5434ebe0cd
--- /dev/null
+++ b/python/Markups/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+Markups: Markups (Wrapper around various text markups)
+Markups:
+Markups: Markups provides a wrapper around various text markup languages.
+Markups: Available by default are Markdown, reStructuredText and Textile, but
+Markups: you can easily add your own markups (used in Retext).
+Markups:
+Markups: Docs: https://pymarkups.readthedocs.io/en/latest/
+Markups:
+Markups:
+Markups:
+Markups: