summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--system/scangearmp2/README9
-rw-r--r--system/scangearmp2/scangearmp2.SlackBuild117
-rw-r--r--system/scangearmp2/scangearmp2.info10
-rw-r--r--system/scangearmp2/slack-desc19
4 files changed, 155 insertions, 0 deletions
diff --git a/system/scangearmp2/README b/system/scangearmp2/README
new file mode 100644
index 0000000000..f4d82f23af
--- /dev/null
+++ b/system/scangearmp2/README
@@ -0,0 +1,9 @@
+scangearmp2 (scanning front-end GUI for Canon Multifunction Inkjet Printer)
+
+scangearmp2 is a scanning program for Canon Multifunction Inkjet Printer.
+You can scan image from Canon Multifunction Inkjet Printer, and select the
+scanning parameters, for example, scan mode, size, etc.
+
+Support MG7500 series, MG6600 series, MG5600 series, MG2900 series,
+MB2000 series, MB2300 series, MB5000 series, MB5300 series, E460 series,
+MX490 series, E480 series.
diff --git a/system/scangearmp2/scangearmp2.SlackBuild b/system/scangearmp2/scangearmp2.SlackBuild
new file mode 100644
index 0000000000..162fcbc20a
--- /dev/null
+++ b/system/scangearmp2/scangearmp2.SlackBuild
@@ -0,0 +1,117 @@
+#!/bin/sh
+
+# Slackware build script for scangearmp2
+
+# Copyright 2019 Kenneth Chan, Hong Kong
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=scangearmp2
+VERSION=${VERSION:-3.90.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=$PRGNAM-source
+SRCVERSION=3.90-1
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+ LDFLAGS="-L$TMP/$SRCNAM-${SRCVERSION}/com/libs_bin32"
+ BITS="i386"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+ LDFLAGS="-L$TMP/$SRCNAM-${SRCVERSION}/com/libs_bin32"
+ BITS="i386"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+ LDFLAGS="-L$TMP/$SRCNAM-${SRCVERSION}/com/libs_bin64"
+ BITS="amd64"
+else
+ echo "Package for $(uname -m) architecture is not available."
+ exit 1
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$SRCVERSION
+
+tar xvzf $CWD/$SRCNAM-${SRCVERSION}.tar.gz
+cd $SRCNAM-$SRCVERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . \
+ \( -type f \! -name autogen.sh \) \
+ -exec chmod 644 {} \;
+
+cd $PRGNAM
+
+./autogen.sh --prefix=/usr LDFLAGS="$LDFLAGS"
+make
+make install-strip DESTDIR=$PKG
+
+# Follow debian/rules
+if [ "$ARCH" = "x86_64" ]; then
+ mv $PKG/usr/lib $PKG/usr/lib64
+ install -s -m 755 ../com/libs_bin64/*.so $PKG/usr/lib64/
+ install -m 666 ../com/ini/canon_mfp2_net.ini $PKG/usr/lib64/bjlib/
+elif [ "$ARCH" = "i586" ]; then
+ install -s -m 755 ../com/libs_bin32/*.so $PKG/usr/lib/
+ install -m 666 ../com/ini/canon_mfp2_net.ini $PKG/usr/lib/bjlib/
+elif [ "$ARCH" = "i686" ]; then
+ install -s -m 755 ../com/libs_bin32/*.so $PKG/usr/lib/
+ install -m 666 ../com/ini/canon_mfp2_net.ini $PKG/usr/lib/bjlib/
+fi
+
+mkdir -p $PKG/lib/udev/rules.d
+install -m 644 etc/80-canon_mfp2.rules $PKG/lib/udev/rules.d
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README ../doc/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/scangearmp2/scangearmp2.info b/system/scangearmp2/scangearmp2.info
new file mode 100644
index 0000000000..977724b7ed
--- /dev/null
+++ b/system/scangearmp2/scangearmp2.info
@@ -0,0 +1,10 @@
+PRGNAM="scangearmp2"
+VERSION="3.90.1"
+HOMEPAGE="https://asia.canon/en/support/0101048701/1"
+DOWNLOAD="http://gdlp01.c-wss.com/gds/7/0100010487/01/scangearmp2-source-3.90-1.tar.gz"
+MD5SUM="6c22dd63e8ed0e8badd5f012f773497d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Kenneth Chan"
+EMAIL="kenneth.t.chan@gmail.com"
diff --git a/system/scangearmp2/slack-desc b/system/scangearmp2/slack-desc
new file mode 100644
index 0000000000..714f021816
--- /dev/null
+++ b/system/scangearmp2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+scangearmp2: scangearmp2 (Front-end GUI for Canon Multifunction Inkjet Printer)
+scangearmp2:
+scangearmp2: A scanning program for Canon Multifunction Inkjet Printer.
+scangearmp2: You can scan image from Canon Multifunction Inkjet Printer, and
+scangearmp2: select the scanning parameters, for example, scan mode, size, etc.
+scangearmp2:
+scangearmp2: Support MG7500 series, MG6600 series, MG5600 series, MG2900 series,
+scangearmp2: MB2000 series, MB2300 series, MB5000 series, MB5300 series, E460
+scangearmp2: series, MX490 series, E480 series.
+scangearmp2:
+scangearmp2: Homepage: https://asia.canon/en/support/0101048701/1