summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/terminado/terminado.SlackBuild7
-rw-r--r--python/terminado/terminado.info8
2 files changed, 8 insertions, 7 deletions
diff --git a/python/terminado/terminado.SlackBuild b/python/terminado/terminado.SlackBuild
index b1bc9f5e62..94bb2da8d4 100644
--- a/python/terminado/terminado.SlackBuild
+++ b/python/terminado/terminado.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for terminado
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=terminado
-VERSION=${VERSION:-0.8.1}
+VERSION=${VERSION:-0.8.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,7 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/terminado/terminado.info b/python/terminado/terminado.info
index e25784b682..fbb25fe6bf 100644
--- a/python/terminado/terminado.info
+++ b/python/terminado/terminado.info
@@ -1,10 +1,10 @@
PRGNAM="terminado"
-VERSION="0.8.1"
+VERSION="0.8.2"
HOMEPAGE="https://terminado.readthedocs.io/en/latest/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/t/terminado/terminado-0.8.1.tar.gz"
-MD5SUM="616515f562939e979b67c72b667afba9"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/t/terminado/terminado-0.8.2.tar.gz"
+MD5SUM="933a1c5ca7c28e59284d0ac7cadce1ea"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="ptyprocess tornado"
+REQUIRES="python3-ptyprocess python3-tornado ptyprocess tornado"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"