summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild b/python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild
index 6c9aab6b2b..5c10a26eca 100644
--- a/python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild
+++ b/python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild
@@ -70,6 +70,9 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if python3 -c 'import sys' 2>/dev/null; then
+ python3 ./setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true