summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/g3dviewer/README7
-rw-r--r--graphics/g3dviewer/g3dviewer.SlackBuild115
-rw-r--r--graphics/g3dviewer/g3dviewer.info10
-rw-r--r--graphics/g3dviewer/slack-desc19
4 files changed, 151 insertions, 0 deletions
diff --git a/graphics/g3dviewer/README b/graphics/g3dviewer/README
new file mode 100644
index 0000000000..b5b8a66bee
--- /dev/null
+++ b/graphics/g3dviewer/README
@@ -0,0 +1,7 @@
+G3D-Viewer is a application which employs the OpenGL and GtkGLExt
+libraries to render a three-dimensional model in a graphical window.
+
+There is also a feature for rendering a thumbnail for use in a
+graphical file manager.
+
+A number of different input file formats are supported.
diff --git a/graphics/g3dviewer/g3dviewer.SlackBuild b/graphics/g3dviewer/g3dviewer.SlackBuild
new file mode 100644
index 0000000000..3935f36780
--- /dev/null
+++ b/graphics/g3dviewer/g3dviewer.SlackBuild
@@ -0,0 +1,115 @@
+#!/bin/sh
+
+# Slackware build script for g3dviewer
+
+# Copyright 2013 S. Randall Sawyer, Maine, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=g3dviewer
+VERSION=${VERSION:-0.2.99.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Silly, I know. But configure and/or Makefile.am is lacking, and
+# this is easier than patching the offending code...
+SLKCFLAGS="$SLKCFLAGS -lm -lX11"
+
+CFLAGS="$SLKCFLAGS" \
+CPPFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux \
+ --enable-static=yes \
+ --with-x \
+ --x-includes=/usr/include/X11 \
+ --x-libraries=/usr/lib
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Apparently, configure and/or Makefile.am is broken...
+mv $PKG/usr/share/man $PKG/usr/man
+# There is a redundant, empty directory to remove...
+rmdir $PKG/usr/share/pixmaps
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING* CREDITS ChangeLog INSTALL NEWS README* TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/g3dviewer/g3dviewer.info b/graphics/g3dviewer/g3dviewer.info
new file mode 100644
index 0000000000..cd1f1c7b97
--- /dev/null
+++ b/graphics/g3dviewer/g3dviewer.info
@@ -0,0 +1,10 @@
+PRGNAM="g3dviewer"
+VERSION="0.2.99.4"
+HOMEPAGE="http://automagically.de/g3dviewer/"
+DOWNLOAD="http://automagically.de/files/g3dviewer-0.2.99.4.tar.gz"
+MD5SUM="b7da4a68dd18309805ea2ca081542cfd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libg3d"
+MAINTAINER="S. Randall Sawyer"
+EMAIL="srandallsawyer at gmail dot com"
diff --git a/graphics/g3dviewer/slack-desc b/graphics/g3dviewer/slack-desc
new file mode 100644
index 0000000000..5b06b0a937
--- /dev/null
+++ b/graphics/g3dviewer/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+g3dviewer: g3dviewer (3-D model viewer)
+g3dviewer:
+g3dviewer: G3D-Viewer is a application which employs the OpenGL and GtkGLExt
+g3dviewer: libraries to render a three-dimensional model in a graphical window.
+g3dviewer:
+g3dviewer: There is also a feature for rendering a thumbnail for use in a
+g3dviewer: graphical file manager.
+g3dviewer:
+g3dviewer: A number of different input file formats are supported.
+g3dviewer:
+g3dviewer: