summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Jason Graham2021-02-26 20:23:28 +0100
committer Willy Sudiarto Raharjo2021-02-27 02:24:28 +0100
commitb0065a0c77b24704f6a08bb5fc82bf6fdb86f512 (patch)
tree2d80a4c9f78e15dbac4b834c7be0d33dab65696e /system
parentb66af19681f23c18c561ad4fb06bdc02b7f1df1a (diff)
downloadslackbuilds-b0065a0c77b24704f6a08bb5fc82bf6fdb86f512.tar.gz
system/lshw: Updated for version B.02.19.2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/lshw/README32
-rw-r--r--system/lshw/lshw.SlackBuild59
-rw-r--r--system/lshw/lshw.info8
3 files changed, 77 insertions, 22 deletions
diff --git a/system/lshw/README b/system/lshw/README
index f917315f0f..04d64576eb 100644
--- a/system/lshw/README
+++ b/system/lshw/README
@@ -1,15 +1,27 @@
-lshw (Hardware Lister) is a small tool to provide detailed information on
-the hardware configuration of the machine. It can report exact memory
-configuration, firmware version, mainboard configuration, CPU version and
-speed, cache configuration, bus speed, etc. on DMI-capable x86 or EFI
-(IA-64) systems and on some PowerPC machines (PowerMac G4 is known to work).
+lshw (Hardware Lister) is a small tool to provide detailed information
+on the hardware configuration of the machine. It can report exact memory
+configuration, firmware version, mainboard configuration, CPU version
+and speed, cache configuration, bus speed, etc. on DMI-capable x86 or
+EFI (IA-64) systems and on some PowerPC machines (PowerMac G4 is known
+to work).
Information can be output in plain text, XML, or HTML.
It currently supports DMI (x86 and EFI only), OpenFirmware device tree
-(PowerPC only), PCI/AGP, ISA PnP (x86), CPUID (x86), IDE/ATA/ATAPI, PCMCIA
-(only tested on x86), USB, and SCSI.
+(PowerPC only), PCI/AGP, ISA PnP (x86), CPUID (x86), IDE/ATA/ATAPI,
+PCMCIA (only tested on x86), USB, and SCSI.
-On x86, lshw needs to be run as root to be able to access DMI information
-from the BIOS. Running lshw as a non-root user usually gives much less
-detailed information.
+On x86, lshw needs to be run as root to be able to access DMI
+information from the BIOS. Running lshw as a non-root user usually gives
+much less detailed information.
+
+There several build options available for the SlackBuild:
+
+ GUI=no Disable GTK GUI support (default: yes)
+ ZLIB=yes Enable zlib support (default: no)
+ SQLITE=yes Enable sqlite support (default: no)
+
+where one or more build options are passed to the SlackBuild. For
+example, to disable GUI and enable zlib support use:
+
+ GUI=no ZLIB=yes ./lshw.SlackBuild
diff --git a/system/lshw/lshw.SlackBuild b/system/lshw/lshw.SlackBuild
index 0b24779004..fdd5409b83 100644
--- a/system/lshw/lshw.SlackBuild
+++ b/system/lshw/lshw.SlackBuild
@@ -1,13 +1,45 @@
#!/bin/sh
# Slackware build script for lshw
-# Written by Iskar Enev <iskar.enev[@]gmail.com>
+
+# Iskar Enev <iskar.enev[@]gmail.com>
+# Copyright 2017,2021 Jason Graham <jgraham@compukix.net> USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=lshw
-VERSION=${VERSION:-B.02.18}
+VERSION=${VERSION:-B.02.19.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+GUI=${GUI:-yes}
+if [ "$ZLIB" = "no" ]; then
+ ENABLE_ZLIB=0
+else
+ ENABLE_ZLIB=1
+fi
+if [ "$SQLITE" = "no" ]; then
+ ENABLE_SQLITE=0
+else
+ ENABLE_SQLITE=1
+fi
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -53,10 +85,19 @@ find -L . \
# Fix the MANDIR variable
sed -i "s%MANDIR=\$(PREFIX)/share/man%MANDIR=\$(PREFIX)/man%" src/Makefile
-RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" make
-RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" make gui
-make install DESTDIR=$PKG
-make install-gui DESTDIR=$PKG
+VERSION=$VERSION RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" \
+ make ZLIB=$ENABLE_ZLIB SQLITE=$ENABLE_SQLITE
+if [ "$GUI" = "yes" ]; then
+ VERSION=VERSION RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" \
+ make gui ZLIB=$ENABLE_ZLIB SQLITE=$ENABLE_SQLITE
+fi
+
+VERSION=$VERSION RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" \
+ make install DESTDIR=$PKG ZLIB=$ENABLE_ZLIB SQLITE=$ENABLE_SQLITE
+if [ "$GUI" = "yes" ]; then
+ VERSION=$VERSION RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" \
+ make install-gui DESTDIR=$PKG ZLIB=$ENABLE_ZLIB SQLITE=$ENABLE_SQLITE
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -64,8 +105,10 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-mkdir -p $PKG/usr/share/applications
-cat $CWD/gtk-lshw.desktop > $PKG/usr/share/applications/gtk-lshw.desktop
+if [ "$GUI" = "yes" ]; then
+ mkdir -p $PKG/usr/share/applications
+ cat $CWD/gtk-lshw.desktop > $PKG/usr/share/applications/gtk-lshw.desktop
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a docs/* COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/system/lshw/lshw.info b/system/lshw/lshw.info
index 4c8d8ae4c5..d6da2e38a2 100644
--- a/system/lshw/lshw.info
+++ b/system/lshw/lshw.info
@@ -1,10 +1,10 @@
PRGNAM="lshw"
-VERSION="B.02.18"
+VERSION="B.02.19.2"
HOMEPAGE="https://ezix.org/project/wiki/HardwareLiSter"
-DOWNLOAD="https://www.ezix.org/software/files/lshw-B.02.18.tar.gz"
-MD5SUM="8671c6d94d6324a744b7f21f1bfecfd2"
+DOWNLOAD="https://www.ezix.org/software/files/lshw-B.02.19.2.tar.gz"
+MD5SUM="8c70d46e906688309095c73ecb9396e3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Jason Graham"
-EMAIL="jgraha8@gmail.com"
+EMAIL="jgraham@compukix.net"