summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author M.Dinslage2010-05-31 17:21:07 +0200
committer Robby Workman2010-06-04 07:55:54 +0200
commit351f895700a314b0f4186884f33b00e92bd89ed1 (patch)
tree91d47e32371be90298960db494f50952e203bfb7 /system
parent11a11c7df9d79a5867d1c15fdd63caffab6d1d28 (diff)
downloadslackbuilds-351f895700a314b0f4186884f33b00e92bd89ed1.tar.gz
system/conky: re-added audacious support.
Signed-off-by: Chess Griffin <chess@chessgriffin.com>
Diffstat (limited to 'system')
-rw-r--r--system/conky/audacious-2.3-fix.txt12
-rw-r--r--system/conky/conky.SlackBuild2
2 files changed, 14 insertions, 0 deletions
diff --git a/system/conky/audacious-2.3-fix.txt b/system/conky/audacious-2.3-fix.txt
new file mode 100644
index 0000000000..ebd1526017
--- /dev/null
+++ b/system/conky/audacious-2.3-fix.txt
@@ -0,0 +1,12 @@
+diff -up conky-1.8.0/configure.ac.00 conky-1.8.0/configure.ac
+--- conky-1.8.0/configure.ac.00 2010-05-25 23:41:05.529674814 -0700
++++ conky-1.8.0/configure.ac 2010-05-25 23:41:34.475430675 -0700
+@@ -149,7 +149,7 @@ AC_ARG_ENABLE([audacious],
+
+ AM_CONDITIONAL(BUILD_AUDACIOUS, test x$want_audacious = xyes -o x$want_audacious = xlegacy)
+ if test x$want_audacious = xyes; then
+- PKG_CHECK_MODULES([Audacious], [audacious >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0])
++ PKG_CHECK_MODULES([Audacious], [audacious >= 1.4.0 audclient dbus-glib-1 glib-2.0 gobject-2.0])
+ conky_CFLAGS="$conky_CFLAGS $Audacious_CFLAGS"
+ conky_LIBS="$conky_LIBS $Audacious_LIBS"
+ save_CPPFLAGS="$CPPFLAGS"
diff --git a/system/conky/conky.SlackBuild b/system/conky/conky.SlackBuild
index 687df1e2af..094c94a82f 100644
--- a/system/conky/conky.SlackBuild
+++ b/system/conky/conky.SlackBuild
@@ -52,6 +52,7 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xjvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
+patch -p1 < $CWD/audacious-2.3-fix.txt
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -69,6 +70,7 @@ CXXFLAGS="$SLKCFLAGS" \
--enable-shared=yes \
--enable-static=no \
--enable-weather-xoap \
+ --enable-audacious \
--enable-mpd=yes \
--enable-rss=yes \
--enable-wlan=yes \