summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Markus Reichelt2013-12-26 21:09:07 +0100
committer Erik Hanson2014-01-07 18:13:05 +0100
commit17af9762056ddc8ab2346337426b47d7ebec4ccc (patch)
tree2a5eac141524e4d46470be51c6afed9932153921 /system
parent83879bf08c64f156f1e782281be90db17b4130b2 (diff)
downloadslackbuilds-17af9762056ddc8ab2346337426b47d7ebec4ccc.tar.gz
system/mksh: Updated for version R48b.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/mksh/TaC-mksh.txt62
-rw-r--r--system/mksh/doinst.sh12
-rw-r--r--system/mksh/mksh.SlackBuild9
-rw-r--r--system/mksh/mksh.info6
4 files changed, 69 insertions, 20 deletions
diff --git a/system/mksh/TaC-mksh.txt b/system/mksh/TaC-mksh.txt
index fb806b6291..fe7b7b39e0 100644
--- a/system/mksh/TaC-mksh.txt
+++ b/system/mksh/TaC-mksh.txt
@@ -12,7 +12,7 @@ if any are found. We don't think so though.)
All paths are relative to The MirOS Project's CVS repository.
-The following files form The MirBSD Korn Shell R46:
+The following files form The MirBSD Korn Shell R48:
- build system
* mksh/Build.sh
- testsuite driver
@@ -48,6 +48,7 @@ The following files form The MirBSD Korn Shell R46:
* mksh/var.c
* mksh/var_spec.h
- upstream provided packaging
+ * mksh/mksh.ico (application icon resource)
* contrib/hosted/tg/deb/mksh/debian/** (Debian)
(except "printf.c" and "uhr")
* mksh/Makefile (MirBSD only, not part of mksh)
@@ -70,14 +71,14 @@ The following files form The MirBSD Korn Shell R46:
All of these files are covered by The MirOS Licence (Appendix A) ex-
cept the upstream provided packaging, some of which were copied from
other places (specifically some of the Debian packaging) and most of
-which do not require a copyright licence.
+which do not require a copyright licence. Appendix D lists the terms
+for the application icon resource.
The creator of mksh acknowledges the contributions of several people
to the Public Domain Korn Shell as well as suggestions and work from
packagers, other developers etc. and everyone else who helped making
mksh what it is today. Thanks! The MirBSD Korn Shell is covered by a
-copyright licence fallback from the original author of the shell. It
-also includes wcwidth by Markus Kuhn.
+copyright licence fallback from the original author of the shell.
The following files belong to mksh and are distributed inside of its
@@ -85,7 +86,7 @@ distfile, but are not part of it. They are provided for convenience,
because they are required on many operating environments for mksh or
some of its features to function:
- source code
- * mksh/strlcpy.c (always needed)
+ * mksh/strlcpy.c (needed if not provided by the OS already)
These files are covered by seperate licences in addition (Appendix C
for now). Some operating environments already provide their functio-
@@ -94,14 +95,15 @@ libbsd package. The files are not compiled into the resulting binary
if their respective functionality is already provided.
-The following files belong to mksh in a less close way, as they pro-
-vide additional functionality less closely coupled or not always de-
-sired. These are not included in the mksh distfile:
+The following files belong to mksh in a less close way, as the files
+provide additional functionality less closely coupled, or not always
+desired. These are not included in the mksh distfile:
- source code
- * src/usr.bin/printf/printf.c (slightly modified UCB printf utili-
- ty code - for the optional, undesired printf(1) builtin)
- *DO NOT* INCLUDE printf AS A SHELL BUILT-IN UNLESS YOU ABSOLUTE-
- LY MUST (otherwise, the preferrable /usr/bin/printf is called)
+ * src/usr.bin/printf/printf.c (UCB printf(1) utility that has been
+ slightly modified, for the optional, undesired printf builtin)
+
+ *DO NOT* INCLUDE printf AS A SHELL BUILT-IN UNLESS IT ABSOLUTELY
+ IS REQUIRED (or else the preferable /usr/bin/printf gets called)
The printf.c file is covered by the UCB three-clause BSD licence, as
shown in Appendix B below.
@@ -206,5 +208,39 @@ ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+Appendix D - Licence for mksh.ico (optional component)
+=================================
+
+The application icon resource comes in its preferred form
+of modification and is an unregistered trademark:
+
+Copyright (c) 2013 Michael Langguth
+Copyright (c) 2006 Benny Siegert
+Copyright (c) 2005 Thorsten Glaser
+
+This icon may be used to refer to The MirBSD Korn Shell and
+its Win32 port. Distribution patches are acceptable as long
+as they modify $KSH_VERSION according to the guidelines that
+are published on the website; forks and works that are not
+derivates are not allowed to use it.
+
+As far as MirBSD is concerned, the files themselves are free
+to modification and distribution under BSD/MirOS Licence, the
+restriction on use stems only from a need to protect it or
+lose it: http://www.mckusick.com/beastie/mainpage/copyright.html
+
+The Shilouette daemon is Copyright (c) 2003 by Rick Collette.
+The MirOS Project may freely use the former ekkoBSD Logo,
+the shilouette Daemon, for MirBSD, on anything the project
+leader sees fit, so long as it pertains to MirBSD in some
+way and the leader gives credit for the original daemon to
+Marshall Kirk McKusick.
+
+The BSD daemon is Copyright (c) 1988 by Marshall Kirk McKusick.
+All Rights Reserved. Individuals may use the daemon for their
+personal use within the bounds of good taste. When reasonably
+possible, the text shown above is to be included.
+
+
__________________________________________________________________
-$MirOS: www/files/TaC-mksh.txt,v 1.12 2013/05/03 13:24:25 tg Exp $
+$MirOS: www/files/TaC-mksh.txt,v 1.18 2013/09/10 16:12:59 tg Exp $
diff --git a/system/mksh/doinst.sh b/system/mksh/doinst.sh
index 83ded97792..ebbd502e4b 100644
--- a/system/mksh/doinst.sh
+++ b/system/mksh/doinst.sh
@@ -1,3 +1,15 @@
if ! grep -q '/bin/mksh' etc/shells ; then
echo "/bin/mksh" >> etc/shells
fi
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+config etc/skel/.mkshrc.new
diff --git a/system/mksh/mksh.SlackBuild b/system/mksh/mksh.SlackBuild
index 5bf80d5a50..b35c8884b6 100644
--- a/system/mksh/mksh.SlackBuild
+++ b/system/mksh/mksh.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for mksh
-# Copyright (c) 2011-2013 Markus Reichelt, Stolberg (Rhld), DE
+# Copyright (c) 2011-2013 Markus Reichelt, Stolberg (Rhld.), DE
# All rights reserved.
#
# Permission to use, copy, modify, and distribute this software for
@@ -26,7 +26,7 @@
# Markus Reichelt, slackbuilds@mareichelt.de, 0xCCEEF115
PRGNAM=mksh
-VERSION=${VERSION:-R46}
+VERSION=${VERSION:-R48b}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -96,15 +96,16 @@ CC=$CC \
ginstall -D -m 755 mksh $PKG/bin/mksh
ginstall -D -m 644 ../mksh.1 $PKG/usr/man/man1/mksh.1
-ginstall -D -m 644 ../dot.mkshrc $PKG/etc/skel/.mkshrc
+ginstall -D -m 644 ../dot.mkshrc $PKG/etc/skel/.mkshrc.new
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/TaC-mksh.txt > $PKG/usr/doc/$PRGNAM-$VERSION/TaC-mksh.txt
+cat ../dot.mkshrc > $PKG/usr/doc/$PRGNAM-$VERSION/dot.mkshrc
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/system/mksh/mksh.info b/system/mksh/mksh.info
index 4365303542..888bcb9c21 100644
--- a/system/mksh/mksh.info
+++ b/system/mksh/mksh.info
@@ -1,8 +1,8 @@
PRGNAM="mksh"
-VERSION="R46"
+VERSION="R48b"
HOMEPAGE="http://mirbsd.de/mksh"
-DOWNLOAD="http://www.mirbsd.org/MirOS/dist/mir/mksh/mksh-R46.tgz"
-MD5SUM="77c108d8143a6e7670954d77517d216d"
+DOWNLOAD="http://www.mirbsd.org/MirOS/dist/mir/mksh/mksh-R48b.tgz"
+MD5SUM="ab9baa6b5a4de9d0e6a3ce9957c18da0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""