summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author B. Watson2023-08-31 08:42:15 +0200
committer Willy Sudiarto Raharjo2023-09-02 13:02:31 +0200
commite54c83670c756ebbe52c780efccd9b3033b33fa2 (patch)
treed143e3ab1b752625e4fcffe52e10037fe80c6b41 /system
parent453baf550fe01d72e8768941cafdd1b7c87a3275 (diff)
downloadslackbuilds-e54c83670c756ebbe52c780efccd9b3033b33fa2.tar.gz
system/borgbackup: Fix conflict with Sphinx.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/borgbackup/README17
-rw-r--r--system/borgbackup/borgbackup.SlackBuild60
-rw-r--r--system/borgbackup/slack-desc2
3 files changed, 35 insertions, 44 deletions
diff --git a/system/borgbackup/README b/system/borgbackup/README
index 5ac7fdc99a..23fb77667b 100644
--- a/system/borgbackup/README
+++ b/system/borgbackup/README
@@ -1,3 +1,5 @@
+borgbackup (deduplicating backup program)
+
BorgBackup (short: Borg) is a deduplicating backup program.
Optionally, it supports compression and authenticated encryption.
@@ -9,17 +11,8 @@ targets.
Borg is a fork of Attic and is maintained by "The Borg collective".
-> **TODO**
->
-> - Switch from `llfuse` to `pyfuse3` for mounting archives.
-> `llfuse` is not maintained any more.
-> - Test dependencies for building the docs.
-> Are there any missing? Are all required?
-
Optional dependencies:
-- llfuse for mounting the archives,
-- Sphinx, alabaster, guzzle_sphinx_theme, imagesize, and python3-attrs
- are required if you wish to build the docs (html, man). Please note
- that the build will fail if Sphinx is installed but the other
- required packages are not.
+- llfuse for mounting the archives.
+- Sphinx and guzzle_sphinx_theme are required if you wish to build the
+ HTML docs. Man pages are always included.
diff --git a/system/borgbackup/borgbackup.SlackBuild b/system/borgbackup/borgbackup.SlackBuild
index 249abbd8b8..b52ea134e6 100644
--- a/system/borgbackup/borgbackup.SlackBuild
+++ b/system/borgbackup/borgbackup.SlackBuild
@@ -22,11 +22,21 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230809 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - stop the build from failing if Sphinx is installed but
+# guzzle_sphinx_theme is not.
+# - always include man pages in package (upstream kindly included
+# prebuilt ones in the tarball).
+# - clean up optional deps for HTML docs in README. python3-attrs
+# is not required, and alabaster + imagesize are already required
+# deps for Sphinx.
+# - make slack-desc say whether the HTML docs are included.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=borgbackup
VERSION=${VERSION:-1.2.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -47,19 +57,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
+# 20230810 bkw: no flags or libdirsuffix, setup.py knows what to do.
set -eu
@@ -76,30 +74,30 @@ chmod -R a-st,u+rwX,go-w+rX .
python3 setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20230810 bkw: faster than the find|file|xargs template stuff.
+find $PKG/usr/lib*/python* -name '*.so' | xargs strip --strip-unneeded
-if [ -x /usr/bin/sphinx-build ]; then
- cd docs
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
- make html
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a _build/html $PKG/usr/doc/$PRGNAM-$VERSION
+# 20230809 bkw: stop the build from failing if Sphinx is installed
+# but guzzle_sphinx_theme is not. upstream's README documents this, even.
+make -C docs html && cp -a docs/_build/html $PKGDOC
- make man
- mkdir -p $PKG/usr/man/man1
- cp -a _build/man/*.1 $PKG/usr/man/man1
- gzip -9 $PKG/usr/man/man1/*.1
+# 20230810 bkw: for the slack-desc:
+WITH_HTML=WITHOUT
+[ -d $PKGDOC/html ] && WITH_HTML=WITH
- cd ..
-fi
+# 20230809 bkw: upstream ships prebuilt man pages, always install.
+mkdir -p $PKG/usr/man/man1
+cp -a docs/man/*.1 $PKG/usr/man/man1
+gzip -9 $PKG/usr/man/man1/*
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CHANGES.rst LICENSE README.rst SECURITY.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cp -a AUTHORS CHANGES.rst LICENSE README.rst SECURITY.md $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
+sed "s,@WITH_HTML@,$WITH_HTML," < $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/borgbackup/slack-desc b/system/borgbackup/slack-desc
index f58dca23e6..cdd0b2e7dd 100644
--- a/system/borgbackup/slack-desc
+++ b/system/borgbackup/slack-desc
@@ -15,5 +15,5 @@ borgbackup: to backup data. The data deduplication technique used makes Borg
borgbackup: suitable for daily backups since only changes are stored. The
borgbackup: authenticated encryption technique makes it suitable for backups
borgbackup: to not fully trusted targets.
-borgbackup:
borgbackup: Homepage: https://borgbackup.readthedocs.io/
+borgbackup: This package was built @WITH_HTML@ the HTML documentation.